Drop support for <pre cols>

RESOLVED FIXED in mozilla29

Status

()

Core
Layout
P4
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: emk, Assigned: emk)

Tracking

({dev-doc-complete, site-compat})

Trunk
mozilla29
dev-doc-complete, site-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DocArea=HTML])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
This is a non-standard extension derived from Navigator. It is not spec'ed and no other browsers support this. A standard alternative, width attribute, is available.
From a quick glance, I'd expect this would basically just require removing both usages of nsGkAtoms::cols from http://mxr.mozilla.org/mozilla-central/source/content/html/content/src/HTMLPreElement.cpp , right?
Version: unspecified → Trunk
Priority: -- → P4
(Assignee)

Comment 2

4 years ago
(In reply to Daniel Holbert [:dholbert] from comment #1)
> From a quick glance, I'd expect this would basically just require removing
> both usages of nsGkAtoms::cols from
> http://mxr.mozilla.org/mozilla-central/source/content/html/content/src/
> HTMLPreElement.cpp , right?

Basically, yes. We can remove a bit more (usages in ParseAttribute and IsAttributeMapped).
Keywords: dev-doc-needed
(Assignee)

Comment 3

4 years ago
Created attachment 8347216 [details] [diff] [review]
Drop support for "cols" attribute of <pre> elements
Attachment #8347216 - Flags: review?(dbaron)
(Assignee)

Comment 4

4 years ago
Try run: https://tbpl.mozilla.org/?tree=Try&rev=9b60d22aa226
Comment on attachment 8347216 [details] [diff] [review]
Drop support for "cols" attribute of <pre> elements

r=dbaron

But what other browsers support the width attribute?  It doesn't seem to be spec'd in HTML5 either, though it was in HTML4.  (Unless I'm looking in the wrong places, which I certainly could be.)
Attachment #8347216 - Flags: review?(dbaron) → review+
(Assignee)

Comment 6

4 years ago
(In reply to David Baron [:dbaron] (needinfo? me) (UTC-5) from comment #5)
> But what other browsers support the width attribute?

Other browsers have HTMLPreElement.width property which will reflect the content attribute.

> It doesn't seem to be
> spec'd in HTML5 either, though it was in HTML4.  (Unless I'm looking in the
> wrong places, which I certainly could be.)

It is defined in the HTML5 spec, but in the Obsolete features section.
http://www.whatwg.org/specs/web-apps/current-work/multipage/obsolete.html#HTMLPreElement-partial
Note that this is defined under "Requirements for implementations" subsection, so user agents must implement this as spec'ed despite that authors must not depend on this feature.

HTML5 spec says nothing about the layout effect of the attribute. Actually, it has no visual effect on other browsers. So I was planning to remove the visual effect of the width element, but in a follow-up bug.
(Assignee)

Comment 7

4 years ago
> width element
width attribute, of course.
(Assignee)

Comment 8

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/4b78a373acbd
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Blocks: 950737
(Assignee)

Comment 9

4 years ago
(In reply to Masatoshi Kimura [:emk] from comment #6)
> I was planning to remove the
> visual effect of the width element, but in a follow-up bug.

Filed bug 950737.
https://hg.mozilla.org/mozilla-central/rev/4b78a373acbd
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Whiteboard: [DocArea=HTML]
https://developer.mozilla.org/en-US/Firefox/Releases/29/Site_Compatibility
Keywords: dev-doc-needed → dev-doc-complete

Updated

3 years ago
Duplicate of this bug: 714242

Comment 13

3 years ago
https://developer.mozilla.org/en-US/docs/Web/HTML/Element/pre
needs an update then ("cols" and "width" attributes don't work since version 29)

Updated

3 years ago
Keywords: dev-doc-complete → dev-doc-needed
Updated
Keywords: dev-doc-needed → dev-doc-complete
You need to log in before you can comment on or make changes to this bug.