Closed Bug 950046 Opened 6 years ago Closed 6 years ago

[holly] Empty row in Web Developer Menu on Windows

Categories

(DevTools :: General, defect)

x86_64
Windows 7
defect
Not set

Tracking

(firefox27 unaffected, firefox28+ verified, firefox29 verified)

VERIFIED FIXED
Future
Tracking Status
firefox27 --- unaffected
firefox28 + verified
firefox29 --- verified

People

(Reporter: adalucinet, Assigned: jryans)

References

Details

(Keywords: regression)

Attachments

(2 files)

Not reproducible on: Firefox 27 beta 1 (Build ID: 20131209204824)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
Reproducible on: latest Aurora (Build ID: 20131212004008) 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
Reproducible on: latest Holly (Build ID: 20131212040201)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

STR:
1. Launch Firefox.
2. Go to Firefox Menu -> Web Developer

Expected results: No empty row displayed between App Manager and Browser Console.

Actual results: An empty row is displayed between App Manager and Browser Console.

Notes: 
1. Only reproducible on Windows OS.
2. Regression range will be posted as soon as found.
Component: Menus → Developer Tools
Keywords: regression
Summary: Empty row in Web Developer Menu → [holly] Empty row in Web Developer Menu on Windows
The empty menu item is this one:
<menuitem id="appmenu_chromeDebugger" observes="devtoolsMenuBroadcaster_ChromeDebugger"/>

There is no such broadcaster on Aurora/Holly:
http://mxr.mozilla.org/mozilla-aurora/search?string=devtoolsMenuBroadcaster_ChromeDebugger

It was removed by bug 912057.
Blocks: 912057
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Fixes up the app menu in Holly.  Will request Aurora after landing there.

Try (build only): https://tbpl.mozilla.org/?tree=Try&rev=35b23b18312c
Attachment #8347564 - Flags: review?(past)
Attachment #8347564 - Flags: review?(past) → review+
Duplicate of this bug: 950448
Verified this fixes the issue in a local VM.

Landed on Holly: https://hg.mozilla.org/projects/holly/rev/5f145f2b29b8
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Future
Comment on attachment 8347564 [details] [diff] [review]
Add Browser Toolbox to app menu

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 912057
User impact if declined: Empty / broken menu item in the Firefox app menu
Testing completed (on m-c, etc.): holly
Risk to taking this patch (and alternatives if risky): Low
String or IDL/UUID changes made by this patch: None
Attachment #8347564 - Flags: approval-mozilla-aurora?
Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

Verified as fixed on latest Holly 29.0a1 (Build ID: 20131218040202).
Triage drive-by - waiting for this to land on central before approving uplift.
(In reply to Lukas Blakk [:lsblakk] from comment #7)
> Triage drive-by - waiting for this to land on central before approving
> uplift.

It won't be in this case, as the change is Aurora / Holly specific.
Flags: needinfo?(lsblakk)
Attachment #8347564 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: needinfo?(lsblakk)
Verified as fixed on the 01/08 Firefox 28.0a2:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.