Closed Bug 950448 Opened 6 years ago Closed 6 years ago

Web Developer splitmenu popup sizing is wrong in App Button on Aurora28.0a2 and Holly29.0a1 on Windows7 Classic Style

Categories

(DevTools :: Debugger, defect, major)

28 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

(firefox27 unaffected, firefox28 affected, firefox29 affected)

RESOLVED DUPLICATE of bug 950046
Tracking Status
firefox27 --- unaffected
firefox28 --- affected
firefox29 --- affected

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot
Build Identifier:
http://hg.mozilla.org/projects/holly/rev/ff302db28367
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20131214040202

The problem happens Windows7 Classic Style only

Steps To Reproduce:
1. Click App Button
2. Click Web Developer > (splitmenu)

Actual Results:
Un expected auto repeat buttons appear at top and bottom of menupopup

Expected Results:
No auto repeat buttons

Regression window(holly)
Good:
http://hg.mozilla.org/projects/holly/rev/5382aec93031
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131202040204
Bad:
http://hg.mozilla.org/projects/holly/rev/3831bd01eb41
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131203040240
Pushlog:
https://hg.mozilla.org/projects/holly/pushloghtml?fromchange=5382aec93031&tochange=3831bd01eb41
Regression window(holly tinderbox)
Good:
http://hg.mozilla.org/projects/holly/rev/49fde22e631e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131202073749
Bad:
http://hg.mozilla.org/projects/holly/rev/1153ef40e4d7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131202154904
Pushlog:
http://hg.mozilla.org/projects/holly/pushloghtml?fromchange=49fde22e631e&tochange=1153ef40e4d7
Attached image screenshot
A garbage menu item exists between "App Manager" and "Browser Console"

probably regressed by bug 912057 and Australis backing out stuff.
Blocks: 912057
Component: Layout → Developer Tools: Debugger
Product: Core → Firefox
The patch of Bug 912057 is fogotten about appButton for Non Australis build(Holly) :(
 
this is definitely regression from Bug 912057.
Severity: normal → blocker
Severity: blocker → major
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 950046
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.