Closed Bug 950070 Opened 6 years ago Closed 6 years ago

Operator name not displayed

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: gerard-majax, Assigned: gerard-majax)

References

Details

(Keywords: regression, Whiteboard: [systemfe])

Attachments

(2 files)

On Inari, Gecko and Gaia master with a Free Mobile SIM card roaming on Orange F network: the network displayed on the lockscreen is '{{ operator }}' instead of 'Orange F'.
Gecko side has the correct info:
I/Gecko   ( 2334): RIL Worker[0]: Handling parcel as REQUEST_OPERATOR
I/Gecko   ( 2334): RIL Worker[0]: Received operator network info.
I/Gecko   ( 2334): RIL Worker[0]: Operator: Orange F,Orange F,20801
blocking-b2g: --- → 1.3?
Keywords: regression
It persists after reset-gaia, and my device is in English.
Attached image 2013-12-13-16-50-28.png
I cannot reproduce this bug with my Unagi:
 • Gaia 8cc6eb43
 • Gecko 20131206144956
 • Free Mobile SIM card roaming on Orange F network
 • English

Trying on other devices…
Just pulled master, reset-gaia, still reproducing. My SIM has a PIN.
Gaia b30d054dd45410560015ea88b5b3e60610f8d0bb
Gecko 5cfcfcf8a4c222a38d7f35ff70d3fb39b3abb129
Blocks: 921390
This is extremely bad. We should get as much as details as possible here to figure out how to fix this.

QA Wanted - Are we able to reproduce this on the US side? If so, does this reproduce on 1.2?
Keywords: qawanted
Don't worry, I have it fixed, a PR is in flight, it's just lacking tests for now.
(In reply to Alexandre LISSY :gerard-majax from comment #8)
> Don't worry, I have it fixed, a PR is in flight, it's just lacking tests for
> now.

Okay - in that case, I'll skip qawanted since this is actionable.
Keywords: qawanted
Can you also check if this happens on 1.2?
Jason: This is a regression from bug 921390, a DSDS bug. So this is 1.3 only.
Assignee: nobody → lissyx+mozillians
Status: NEW → ASSIGNED
Please find attached a pull request fixing the issue.

Travis is running at https://travis-ci.org/mozilla-b2g/gaia/builds/15413655, previous build (same pull request without the test) was green, so we should have it green soon.
Attachment #8347360 - Flags: review?(kaze)
Travis is green \o/
Attachment #8347360 - Flags: review?(kaze) → review+
https://github.com/mozilla-b2g/gaia/commit/ff5a87e8c13c14d14f04ce912b473c199f4ab870
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [systemfe]
bad regression, so blocking+
blocking-b2g: 1.3? → 1.3+
Uplifted ff5a87e8c13c14d14f04ce912b473c199f4ab870 to:
v1.3: 89c11ad70d6d642643d2d6a4a26190d85b286802
You need to log in before you can comment on or make changes to this bug.