Bing search suggestions on desktop do not include locale

RESOLVED FIXED in Firefox 29

Status

()

Firefox
Search
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mconnor, Assigned: mconnor)

Tracking

unspecified
Firefox 29
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first verify])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
We only use one Bing plugin for all locales, so we don't have the right results in autocomplete for a user's locale.

Compare:

http://api.bing.com/osjson.aspx?query=automobile&form=OSDJAS
http://api.bing.com/osjson.aspx?query=automobile&form=OSDJAS&market=ja-JP
http://api.bing.com/osjson.aspx?query=automobile&form=OSDJAS&market=de-DE
http://api.bing.com/osjson.aspx?query=automobile&form=OSDJAS&market=en-US

The obvious fix is to add market={moz:locale} to the bing plugin as a param to suggestions, waiting on Bing to verify that's the correct thing to do.
(Assignee)

Comment 1

4 years ago
Created attachment 8349740 [details] [diff] [review]
bingDesktopLangFix

Verified in Fx26 DE that we're getting en-US suggestions in .de, which is rather suboptimal.  This is the correct param, per Bing.
Attachment #8349740 - Flags: review?(gavin.sharp)
Duplicate of this bug: 604979
Comment on attachment 8349740 [details] [diff] [review]
bingDesktopLangFix

Exacerbates bug 670451, but that's more than made up for by the UX win.
Attachment #8349740 - Flags: review?(gavin.sharp) → review+

Comment 4

4 years ago
Note, this will send "market=de" instead of "market=de-DE". I didn't see a difference in the sample query, just stating this in case we need to make that explicit to the bing folks.
(Assignee)

Comment 5

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/8e64c79bb855

Axel, that's a good point, I'll flag it for the Bing folks.
https://hg.mozilla.org/mozilla-central/rev/8e64c79bb855
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29

Comment 7

4 years ago
(In reply to Axel Hecht [:Pike] from comment #4)
> Note, this will send "market=de" instead of "market=de-DE". I didn't see a
> difference in the sample query, just stating this in case we need to make
> that explicit to the bing folks.

It does make a difference for me in Sweden. "market=de" does not give me the same results as "market=de-DE". Instead I get the same results as "market=sv-SE" (and "market=sv") gives me. It looks like Bing do not recognize short locale codes and use other means to guess the users locale, like their IP address.

Updated

4 years ago
Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.