Bing doesn't switch locale automatically

RESOLVED DUPLICATE of bug 950204

Status

()

RESOLVED DUPLICATE of bug 950204
8 years ago
5 years ago

People

(Reporter: rimas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 483825 [details]
HTTP log

This is an offspring from bug 603298.
The problem is that with Lithuanian version of Firefox, Bing doesn't automatically use Lithuanian locale for me, which it has. Instead, I'm only presented with a link at the top of the page which allows me to switch manually.

I'm attaching an HTTP log from a fresh profile. It's a bit littered with a few unrelated things loading (the firstrun pages), but I hope usefull stuff can be filtered out. I used bing.xml file from the attachment on bug 603298.

Comment 1

8 years ago
Hrm. Can't reproduce, I get lithuanian results with your accept-lang settings from Berlin. Let's figure out if we have different service providers? This is what I get for dig and traceroute:

wokbok:html-preso-template axelhecht$ dig www.bing.com

; <<>> DiG 9.6.0-APPLE-P2 <<>> www.bing.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 3208
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 8, ADDITIONAL: 7

;; QUESTION SECTION:
;www.bing.com.			IN	A

;; ANSWER SECTION:
www.bing.com.		3468	IN	CNAME	search.ms.com.edgesuite.net.
search.ms.com.edgesuite.net. 6150 IN	CNAME	a134.g.akamai.net.
a134.g.akamai.net.	20	IN	A	173.223.232.146
a134.g.akamai.net.	20	IN	A	173.223.232.162

;; AUTHORITY SECTION:
g.akamai.net.		844	IN	NS	n1g.akamai.net.
g.akamai.net.		844	IN	NS	n2g.akamai.net.
g.akamai.net.		844	IN	NS	n5g.akamai.net.
g.akamai.net.		844	IN	NS	n6g.akamai.net.
g.akamai.net.		844	IN	NS	n3g.akamai.net.
g.akamai.net.		844	IN	NS	n7g.akamai.net.
g.akamai.net.		844	IN	NS	n0g.akamai.net.
g.akamai.net.		844	IN	NS	n4g.akamai.net.

;; ADDITIONAL SECTION:
n0g.akamai.net.		1127	IN	A	96.17.144.44
n2g.akamai.net.		1338	IN	A	96.17.144.43
n3g.akamai.net.		1127	IN	A	96.17.144.44
n4g.akamai.net.		1079	IN	A	96.17.144.45
n5g.akamai.net.		1338	IN	A	96.17.144.40
n6g.akamai.net.		1127	IN	A	96.17.144.45
n7g.akamai.net.		373	IN	A	96.17.144.44

;; Query time: 212 msec
;; SERVER: 10.2.74.125#53(10.2.74.125)
;; WHEN: Sun Oct 17 14:31:59 2010
;; MSG SIZE  rcvd: 387

wokbok:html-preso-template axelhecht$ traceroute www.bing.com
traceroute: Warning: www.bing.com has multiple addresses; using 173.223.232.162
traceroute to a134.g.akamai.net (173.223.232.162), 64 hops max, 52 byte packets
 1  192.168.1.1 (192.168.1.1)  4.110 ms  5.128 ms  7.717 ms
 2  rdsl-brln-de01.nw.mediaways.net (213.20.59.131)  20.022 ms  19.851 ms  23.091 ms
 3  xmwc-brln-de02-chan-18.nw.mediaways.net (195.71.188.102)  19.826 ms  21.947 ms  22.114 ms
 4  10gigabitethernet1-1.core1.lon1.he.net (195.66.224.21)  46.229 ms  45.766 ms  46.359 ms
 5  10gigabitethernet4-4.core1.nyc4.he.net (72.52.92.241)  114.712 ms  121.443 ms  125.293 ms
 6  10gigabitethernet2-3.core1.ash1.he.net (72.52.92.86)  126.056 ms  120.891 ms  124.728 ms
 7  10gigabitethernet1-4.core1.pao1.he.net (72.52.92.29)  192.640 ms  200.061 ms  200.044 ms
 8  akamai-technologies-inc.10gigabitethernet2-4.core1.pao1.he.net (66.220.31.234)  510.011 ms  709.653 ms  305.993 ms
 9  a173-223-232-162.deploy.akamaitechnologies.com (173.223.232.162)  189.256 ms  198.431 ms  208.961 ms
(Reporter)

Comment 2

8 years ago
$ dig www.bing.com

; <<>> DiG 9.7.1-P2 <<>> www.bing.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15904
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 8, ADDITIONAL: 8

;; QUESTION SECTION:
;www.bing.com.			IN	A

;; ANSWER SECTION:
www.bing.com.		403	IN	CNAME	search.ms.com.edgesuite.net.
search.ms.com.edgesuite.net. 16828 IN	CNAME	a134.g.akamai.net.
a134.g.akamai.net.	20	IN	A	217.212.252.136
a134.g.akamai.net.	20	IN	A	217.212.252.171

;; AUTHORITY SECTION:
g.akamai.net.		597	IN	NS	n1g.akamai.net.
g.akamai.net.		597	IN	NS	n2g.akamai.net.
g.akamai.net.		597	IN	NS	n0g.akamai.net.
g.akamai.net.		597	IN	NS	n6g.akamai.net.
g.akamai.net.		597	IN	NS	n7g.akamai.net.
g.akamai.net.		597	IN	NS	n5g.akamai.net.
g.akamai.net.		597	IN	NS	n3g.akamai.net.
g.akamai.net.		597	IN	NS	n4g.akamai.net.

;; ADDITIONAL SECTION:
n7g.akamai.net.		1414	IN	A	217.212.252.148
n4g.akamai.net.		63	IN	A	217.212.252.143
n0g.akamai.net.		307	IN	A	92.122.212.31
n2g.akamai.net.		2125	IN	A	62.156.238.6
n1g.akamai.net.		1991	IN	A	62.156.238.5
n6g.akamai.net.		790	IN	A	217.212.252.150
n3g.akamai.net.		1067	IN	A	217.212.252.141
n5g.akamai.net.		2125	IN	A	217.212.252.167

;; Query time: 169 msec
;; SERVER: 212.59.0.1#53(212.59.0.1)
;; WHEN: Sun Oct 17 16:09:28 2010
;; MSG SIZE  rcvd: 403


$ traceroute www.bing.com
traceroute to www.bing.com (217.212.252.136), 30 hops max, 60 byte packets
 1  192.168.1.1 (192.168.1.1)  1.083 ms  1.366 ms  2.506 ms
 2  * * *
 3  213-190-41-21.static.telecom.lt (213.190.41.21)  88.146 ms  88.454 ms  88.556 ms
 4  81-7-120-177.static.zebra.lt (81.7.120.177)  88.737 ms *  97.766 ms
 5  war-b3-link.telia.net (213.248.85.89)  107.898 ms  108.004 ms  108.188 ms
 6  hls-b2-link.telia.net (80.91.246.202)  126.024 ms  133.183 ms  209.408 ms
 7  hls-b1-link.telia.net (80.91.252.158)  210.926 ms  211.919 ms  213.096 ms
 8  217-212-252-136.customer.teliacarrier.com (217.212.252.136)  215.059 ms  216.176 ms  218.143 ms
(Reporter)

Comment 3

8 years ago
I would guess that what a134.g.akamai.net resolves to is probably a bit random, ain't it?
(Reporter)

Updated

7 years ago
Blocks: 732228

Comment 4

7 years ago
I'm not sure how random it is, but you seem to end up in a rather different outlet.

Kev, Carsten, can you ask our contacts at bing for details?
(Reporter)

Comment 5

6 years ago
Kev, Carsten, ping!
will look at this
(Reporter)

Comment 7

6 years ago
Has anyone ever looked at this?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 950204
You need to log in before you can comment on or make changes to this bug.