Closed Bug 950231 Opened 7 years ago Closed 7 years ago

Reverting a page doesn't take effect until a shift-reload of the page

Categories

(developer.mozilla.org Graveyard :: General, defect)

All
Other
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 839819

People

(Reporter: sheppy, Unassigned)

References

Details

(Whiteboard: [specification][type:bug])

What did you do?
================
1. Revert an edit to a page (such as it being translated into another language)

What happened?
==============
The revert works, but loading the page continues to give you the most recent version instead of the one you reverted to. Force refresh the page and it rebuilds and you get the right content.

What should have happened?
==========================
We need to automatically rebuild pages on revert. Otherwise this will continue to happen and we'll keep having people think they've fixed a problem only to have it still there for sometimes weeks before someone notices and does the shift-reload.

Is there anything else we should know?
======================================
Just now, I had to do this to fix a page that Janet reverted on December 3 after someone translated it into German in-place. That means that for a week and a half, this page was in German instead of English. That's not cool.
Making this a post-launch bug.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 839819
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/87c719ddc55ef2ef9b90a9d642d7ea5176a3cda3
bug 950231: Render document after revision revert

* Schedule document rendering after revert

* Force doc rendering Celery task to load fresh document instance

* Use autocommit mode for revert_document, so kumascript gets current content

https://github.com/mozilla/kuma/commit/8006db99f42e05df2305d110f03d11e734aa7a60
Merge pull request #1950 from lmorchard/950231-rebuild-after-revert

bug 950231: Schedule document rendering after a revision is reverted
Product: developer.mozilla.org → developer.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.