Closed Bug 950256 Opened 9 years ago Closed 8 years ago

Linux fuzzer jobs are failing due to a wget certificate error

Categories

(Infrastructure & Operations Graveyard :: CIDuty, task, P3)

x86
Linux

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jruderman, Assigned: coop)

Details

zcat fuzzer-linux-bm57-build1-build50880.txt.gz

builder: fuzzer-linux
slave: bld-centos5-32-vmw-003

...

inpCmdList is: wget -O - https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux-debug/
stdout: ''
stderr: "--15:05:43--  https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux-debug/\nResolving ftp.mozilla.org... 63.245.215.56\nConnecting to ftp.mozilla.org|63.245.215.56|:443... connected.\nERROR: cannot verify ftp.mozilla.org's certificate, issued by `/C=US/O=DigiCert Inc/CN=DigiCert Secure Server CA':\n  Unable to locally verify the issuer's authority.\nTo connect to ftp.mozilla.org insecurely, use `--no-check-certificate'.\nUnable to establish SSL connection.\n"

...

Exception: The following exit code was returned: 1
I could work around this by adding --no-check-certificate to downloadBuild.py, but it would be better if I didn't have to.  I think this worked before...
Found in triage. Moving to platform support as first guess, but maybe this should be moved to GeneralAutomation?
Component: Other → Platform Support
QA Contact: joduinn → coop
(In reply to Jesse Ruderman from comment #1)
> I could work around this by adding --no-check-certificate to
> downloadBuild.py, but it would be better if I didn't have to.  I think this
> worked before...

This sounds like a good interim solution. This platform (bld-centos5-32-vmw) is going away soon, so we should make sure this is fixed properly on our AWS slaves where this should be running once bug 803764 is fixed.
I added --no-check-certificate as a workaround, but only on Linux slaves.
Assignee: nobody → coop
Priority: -- → P3
Fixed by bug 803764 it seems.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Component: Platform Support → Buildduty
Product: Release Engineering → Infrastructure & Operations
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.