warning in mozilla-central/netwerk/sctp/src/user_recv_thread.c

RESOLVED DUPLICATE of bug 916427

Status

()

RESOLVED DUPLICATE of bug 916427
5 years ago
5 years ago

People

(Reporter: iosifadrianmihai, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0 (Beta/Release)
Build ID: 20130201190337

Steps to reproduce:

./mach build


Actual results:

Warning: -Wsign-compare in /home/andu/mozilla/mozilla-central/netwerk/sctp/src/user_recv_thread.c: comparison between signed and unsigned integer expressions
 3:58.43 /home/andu/mozilla/mozilla-central/netwerk/sctp/src/user_recv_thread.c:485:25: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
(Reporter)

Comment 1

5 years ago
Created attachment 8347621 [details] [diff] [review]
p1.patch

First patch ever
Fixed warning in mozilla-central/netwerk/sctp/src/user_recv_thread.c: comparison between signed and unsigned integer expressions
 3:58.43 /mozilla-central/netwerk/sctp/src/user_recv_thread.c:485:25: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
added explicit cast to int to MLEN
Attachment #8347621 - Flags: review?(mcmanus)
(Reporter)

Comment 2

5 years ago
Created attachment 8347795 [details] [diff] [review]
Fixes warning; Changed cast to unsigned int.
Attachment #8347621 - Attachment is obsolete: true
Attachment #8347621 - Flags: review?(mcmanus)
Attachment #8347795 - Flags: review?(mcmanus)
(Reporter)

Updated

5 years ago
Component: General → Networking
Attachment #8347795 - Flags: review?(mcmanus) → review?(rjesup)
Michael: is this fixed by your upstream change as well?
Flags: needinfo?(tuexen)

Comment 4

5 years ago
The upstream code reads:

	int iovlen = MCLBYTES;
	int want_ext = (iovlen > MLEN)? 1 : 0;

and the patch of yesterday gives you
#define	MLEN		((int)(MSIZE - sizeof(struct m_hdr)))

So there should no patch be necessary anymore.

Short answer: Yes, this is fixed also.
Flags: needinfo?(tuexen)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 916427

Updated

5 years ago
Attachment #8347795 - Flags: review?(rjesup)
You need to log in before you can comment on or make changes to this bug.