Closed Bug 950357 Opened 6 years ago Closed 6 years ago

The About dialog automatically checks for updates (and then asks the user if he wants to update) even when the "Never check for updates" option is selected.

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 29

People

(Reporter: fehe, Assigned: steffen.wilberg)

References

Details

(Keywords: regression)

Attachments

(1 file)

Now opening the About dialog causes Firefox to check for updates, even though "Never check for updates" is the chosen option.

This is a regression from bug 600500.
Blocks: 600500
Keywords: regression
Confirmed on Nightly on Win7 64.
Doesn't happen in Aurora on same platform.
Steffen, can you take a look?
Flags: needinfo?(steffen.wilberg)
Confirm Win XP SP3

Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20131214040202 CSet: ff302db28367
This works as intended.

Firefox honors the option "Never check for updates" by never checking for updates *in the background* and therefore never prompting you to install a newer version. However, if you deliberately open the About Firefox dialog, you are implicitly asking the question: "OK, I know I have updates set to manual, I might be behind, so what version of Firefox is this, and is there an update available?" That's the main purpose of the About dialog. The About dialog answers that question by checking for updates and telling you whether or not an update is available. If you really don't want to check for updates, why would you open the About dialog in the first place?

I don't think there's any harm in checking for updates if you open the About dialog, because we then let the user make a conscious decision whether or not he wants to install the update by displaying the button "Update to 30.0".
There is only one case where even the About dialog never checks for updates: the "adminDisabled" case. If the system administrator has not only disabled updates, but also locked the pref "app.update.enabled", so that the user can't enable updates, the About dialog doesn't check for updates, but displays "Updates disabled by your system administrator".


If you've set "Check for updates, but let me decide whether to install them", Firefox *does check for updates in the background* and displays a small notification or a large dialog (not the About dialog), asking whether or not you want to download and install it. The About dialog behaves likewise, it checks for updates and displays a "Update to 30.0" button if updates are available.

If you've set updates to be automatic, Firefox checks, downloads and installs in the background. The next time you restart Firefox, you're on the new version automatically. If you don't restart in a while, Firefox prompts you to so it can switch to the updated version it has already installed in the background.
Flags: needinfo?(steffen.wilberg)
I tried to explain that in the following comment in aboutDialog.js:
136   // If app.update.enabled is false, we don't pop up an update dialog
137   // automatically, but opening the About dialog is considered manually
138   // checking for updates, so we always check.
139   // If app.update.auto is false, we ask before downloading though,
140   // in onCheckComplete.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Just out of interest, when was this "intention" changed? 

I've been using Firefox since it was Bon Echo, and this was never the behavior until yesterday.
In bug 600500, which landed less than 3 days ago in Nightly.
Thank you. I've made a recommendation in bug 600500 for a small UI amendment.
While I personally think it's harmless to just check for updates when opening the About Dialog, the current wording of the option leaves that unclear, and implying that opening About means Check for update is not ideal. I think we should try to still honor the pref description, and I think it's simple to do.

In bug 600500 we removed the implication of "Check for updates means download & install it", so I think it's fair to remove this one too.

Note that this option should never be used by normal users anyway, and the very very few people that want to use it is the kind of user who wants total control of the update process.
Status: RESOLVED → REOPENED
OS: Windows 8.1 → All
Hardware: x86_64 → All
Resolution: INVALID → ---
I have to admit that I don't quite understand why anybody would not even want to check for updates when opening the About dialog. But OK, I'll reimplement the "Check for Updates" button in the "never check" case.
Assignee: nobody → steffen.wilberg
Again, thank you, Mr. Wilberg, and you, Mr. Gomes, for understanding my concern. I'm sorry to make the extra work for you.
I use this option on nightlies, so I update when I want too. If I know there is recent regression that I want to avoid (till its fixed) and stay on an slightly older build.
Summary: "Never check for updates" option is no longer honored → The About dialog automatically checks for updates (and then asks the user if he wants to update) even when the "Never check for updates" option is selected.
Attached patch never-check.diffSplinter Review
This was easy to implement indeed, by adding just another panel.

As for the implementation of "Never check for updates" in the prefwindow, the getter just looks at the app.update.enabled pref. If it's disabled, the "Never check for updates" radio box is selected.
http://mxr.mozilla.org/mozilla-central/source/browser/components/preferences/advanced.js#645
(The setter sets both app.update.enabled and app.update.auto to false, but that doesn't matter).
So in the About dialog, it's sufficient to check for the app.update.enabled.pref.
Attachment #8347778 - Flags: review?(felipc)
(In reply to mdew from comment #12)
> I use this option on nightlies, so I update when I want too. If I know there
> is recent regression that I want to avoid (till its fixed) and stay on an
> slightly older build.

There is no regression that causes or forces you to update when "never" is selected
Comment on attachment 8347778 [details] [diff] [review]
never-check.diff

Review of attachment 8347778 [details] [diff] [review]:
-----------------------------------------------------------------

Perfect, thanks!
Attachment #8347778 - Flags: review?(felipc) → review+
https://hg.mozilla.org/integration/fx-team/rev/fe1973c6c1b7
Target Milestone: --- → Firefox 29
https://hg.mozilla.org/mozilla-central/rev/fe1973c6c1b7
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 951907
(In reply to Steffen Wilberg from comment #10)
> I have to admit that I don't quite understand why anybody would not even
> want to check for updates when opening the About dialog. 
I always get the date/version of the build by there.
Checking the "Never check for updates" pref and then opening the Help/About dialog displays first the "Check for updates" button. If pressed, then the "Update to 29.0a1" button shows up.
Verified fixed FF 29.0a1(2014-01-08), win 7 x64
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.