[Download Manager] The % of the download is not displayed in a notification for files with long names

VERIFIED FIXED in Firefox OS v1.4

Status

Firefox OS
Gaia::System
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: rafael.marquez, Assigned: crdlc)

Tracking

(Blocks: 1 bug)

unspecified
1.3 C3/1.4 S3(31jan)
Other
Other

Firefox Tracking Flags

(blocking-b2g:1.4+, b2g-v1.4 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8347970 [details]
nombre largo.jpg

*Procedure
1. Download a  file
2. Open notification bar during the download process

*Expected result
the % of the download and file name are displayed during the download

*Actual Result
The % of the download is not displayed in a notification for files with long names
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 1.4?
Whiteboard: [systemsfe]
(Assignee)

Updated

4 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 years ago
Hi Francis,

   I was thinking about this issue and I would like to suggest an idea. I think that is better to use this alternative:

<n><%> <separator> <filename.ext>

instead of this one

<filename.ext> <separator> <n><%>

   I guess that it looks better IMHO

10% - my_file_name_very_lon...

   than

my_file_name_very_lon... - 10%

What do you think about this new alternative?

This second alternative is also for free regarding to implementation. The first approach is more complicated from my side. This is not a strong blocker so up to you

Thanks a lot Francis
(Assignee)

Comment 2

4 years ago
I forgot to add the needinfo :(
Flags: needinfo?(fdjabri)
(Assignee)

Comment 3

4 years ago
Hi, any update? Thanks a lot
(Reporter)

Comment 4

4 years ago
any UX update?
Hi Cristian, sorry for the late reply. I agree with your approach - I will make an update to the Spec to address this. Keeping myself as need info for now.
Duplicate of this bug: 961358
(Assignee)

Comment 7

4 years ago
Created attachment 8364385 [details]
Patch v1
Attachment #8364385 - Flags: review?(francisco.jordano)
Comment on attachment 8364385 [details]
Patch v1

Clever ;)
Attachment #8364385 - Flags: review?(francisco.jordano) → review+
(Assignee)

Comment 9

4 years ago
Merged in master:

https://github.com/crdlc/gaia/commit/bb326d71034aeb9acabb0319886896511e179e41
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
(Reporter)

Comment 10

4 years ago
Verified in master
Status: RESOLVED → VERIFIED
blocking-b2g: 1.4? → 1.4+
Spec updated in version 0.15 on Box at: https://mozilla.box.com/s/gw84uv5ykmufiec4acl3
Flags: needinfo?(fdjabri)
(In reply to Francis Djabri [:djabber] from comment #11)
> Spec updated in version 0.15 on Box at:
> https://mozilla.box.com/s/gw84uv5ykmufiec4acl3

Sorry, actually in version 0.16 - https://mozilla.box.com/s/5q5rehaw2z2kgyeag43n

Version 0.16 updates the document to account for this bug but has no other changes from version 0.15.
status-b2g-v1.4: --- → fixed
You need to log in before you can comment on or make changes to this bug.