bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

plugins.hide_infobar_for_blocked_plugin does not work




4 years ago
11 months ago


(Reporter: Artem Kuroptev, Unassigned)


26 Branch
Windows 7

Firefox Tracking Flags

(Not tracked)



(1 attachment, 1 obsolete attachment)



4 years ago
Created attachment 8348128 [details]
Screen Shot 2013-12-16 at 20.50.30.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

I have set plugins.hide_infobar_for_blocked_plugin to TRUE in the about:config section.

Actual results:

An infobar with the following text appears: Allow SITE to run "Adobe Flash"?

Expected results:

No infobar, yet the plugin icon in the address bar to allow the plugin (if needed).


4 years ago
Attachment #8348128 - Attachment is obsolete: true

Comment 1

4 years ago
As it turned out, the infobar can not be captured with the "screenshot" command in the developer console.

Comment 2

4 years ago
Created attachment 8348140 [details]
Infobar is shown despite on "plugins.hide_infobar_for_blocked_plugin=true"

Correct screenshot added.

Comment 3

4 years ago
Doesn't look like that pref is used anywhere in 26+, despite being defined.  I don't know about 25 and earlier.

Component: Untriaged → General

Comment 4

4 years ago
Please see bug 870112. If using plugins.notifyMissingFlash works fine, this bug can be closed as invalid.

Comment 5

4 years ago
plugins.notifyMissingFlash not helping. And I have Flash installed, so it is not "missing", but "blocked" with click-to-play settings. 

Here is screenshot with infobar -- https://bugzilla.mozilla.org/attachment.cgi?id=8348140


4 years ago
Component: General → Plug-ins
Product: Firefox → Core

Comment 6

4 years ago
You want https://addons.mozilla.org/en-US/firefox/addon/hide-plugin-notifications/

We do not intend to add a hidden pref to control this.
Last Resolved: 4 years ago
Resolution: --- → INVALID

Comment 7

4 years ago
Understood, thanks for the answer.

However, I am bit concerned about the fact that some 3rd party addon is required to bring the browser to its normal state. 

I mean, if I need to use Flash (or any other plugin) on most of sites, why would I turn it off ("Ask to activate") in the plugin settings? And if I turned off Flash (set to "Ask to activate"), why would I need a popup infobar on each and every site which uses Flash? - it's annoying! If I need Flash to be turned on on this exactly site, I can turn it by clicking on plugin icon in the address or on the plugin's area on the page.

Comment 8

4 years ago
I should emphasize the conversation above means there is now _no_ apparent way of enabling click-to-play for all plugins.

For people like me who were relying on plugin.default.state=1 to enable click-to-play for all plugins, now we have to click twice to enable, for example, Google Talk plugin. One can set plugin.default.state to always allow but, for some reason, on Youtube the flash plugin does not ask to activate using the infobar (or maybe it did the first time and a configuration is kept somewhere).

So, for now, there is inconsistent behavior when trying to achieve click-to-play for all plugins.

Comment 9

4 years ago
As I just have found, there is a way to eliminate infobar without use of 3rd party plugins (well, I have had the plugin installed to find this out):

The following code has to be added to %profile%\chrome\userChrome.css:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
notification[value="plugin-hidden"] {
  display: none !important;

Comment 10

4 years ago
"We do not intend to add a hidden pref to control this."
I'm sorry, but is there any reason?
Also, what is the purpose of plugins.hide_infobar_for_blocked_plugin?

Comment 11

4 years ago
It has no purpose and should probably be removed from the prefs list.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #11)
> It has no purpose and should probably be removed from the prefs list.

Filed bug 1027049.

Comment 13

3 years ago
"We do not intend to add a hidden pref to control this."

Why? The prefs are made for this! I don't want to install any plugin just to disable annoying "features".
Per e.g. comment 9 its not hard to change this with user style modification (or package that into an addon), so there is no need to implement a pref for that.

Comment 15

3 years ago
But style modifications are overwritten with any update. And addons are annoying, especially for this kind of stuff.

Comment 16

3 years ago
As of now (FF35, updated from 32) none of the workarounds in the thread are working.
Very very annoying behavior is back again!
Please advise. Annoying enough to downgrade to perfectly working and known 32. All the corresponding and eligible prefs are carried on from previous versions and double checked them.

Comment 17

3 years ago
In which site? I'm on Nightly and seen no such behaviour.

Please tell us the site you are having problems with.

Comment 18

3 years ago
On youtube and others.
FF35, updated yesterday. I had (still present) the userChrome.css workaround working for months ever since this surfaced as a problem.

Comment 19

3 years ago
After several restarts now it seems FF35 behaves as before. Have been restarting it 3-4 times to disable addons etc., then restore addons, but didn't help. Now after few more ordinary restarts it seems back on track.

Comment 20

3 years ago
Let me point out that, as of the last year or so, there's a plugin icon in the address bar that one can use to enable the plugin, so the infobar is redundant; and since a click-to-play user very rarely does want to enable a plugin, it's noise. Add a hidden preference or don't, but please get rid of the infobar by default.

Comment 21

3 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #6)
> You want
> https://addons.mozilla.org/en-US/firefox/addon/hide-plugin-notifications/
> We do not intend to add a hidden pref to control this.

Problem with proposed solution is that... at one point it simply stop to work, like just now. So the user ends up being annoying with completely useless bar.

Comment 22

3 years ago
As of this writing, the infobar seems to be dead and gone.

Comment 23

2 years ago
So we have Firefox 47 and following doesn't work:
* add-on: https://addons.mozilla.org/en-US/firefox/addon/hide-plugin-notifications/
* userChrome snippet.

How one gets rid of this annoying notification which pops up on almost every second page?! (I still need flash installed for this 1-2 sites but I completely and utterly don't need it anywhere else)...
Indeed, this is still _extremely_ annoying, particularly because the infobar displaces content right around the time I'm trying to interact with it.
You need to log in before you can comment on or make changes to this bug.