If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Toggle HwcComposer2D on the fly

RESOLVED FIXED in Firefox 28, Firefox OS v1.3

Status

()

Core
Widget: Gonk
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: diego, Assigned: diego)

Tracking

(Blocks: 1 bug)

unspecified
mozilla29
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:1.3+, firefox27 wontfix, firefox28 fixed, firefox29 fixed, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

4 years ago
Patches incoming
(Assignee)

Comment 1

4 years ago
Created attachment 8348207 [details] [diff] [review]
Part 1 - gecko patch - v1
(Assignee)

Comment 2

4 years ago
Created attachment 8348210 [details] [review]
Part 2 - gaia pull request
(Assignee)

Comment 3

4 years ago
Comment on attachment 8348207 [details] [diff] [review]
Part 1 - gecko patch - v1

Hi Nick,

These changes make it so you can toggle the hardware composer on/off at any point without restarting B2G. What do you think?
Attachment #8348207 - Flags: feedback?(ncameron)

Comment 4

4 years ago
Comment on attachment 8348207 [details] [diff] [review]
Part 1 - gecko patch - v1

Review of attachment 8348207 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm

::: modules/libpref/src/init/all.js
@@ +4108,5 @@
>  #endif
>  
>  // ANDROID covers android and b2g
>  #ifdef ANDROID
> +pref("layers.composer2d.enabled", true);

you should put this pref in b2g/app/b2g.js instead of here
Attachment #8348207 - Flags: feedback?(ncameron) → feedback+
(Assignee)

Comment 5

4 years ago
Created attachment 8348395 [details] [diff] [review]
Part 1 - gecko patch - v2
Attachment #8348207 - Attachment is obsolete: true
Attachment #8348395 - Flags: review?(ncameron)
(Assignee)

Updated

4 years ago
Attachment #8348210 - Flags: review?(ncameron)
(Assignee)

Comment 6

4 years ago
Tested on JB and ICS

Comment 7

4 years ago
Comment on attachment 8348210 [details] [review]
Part 2 - gaia pull request

I'm not really sure how to review this. I assume the gaia part will get a review on Github, so not sure what needs doing here.
Attachment #8348210 - Flags: review?(ncameron)

Comment 8

4 years ago
Comment on attachment 8348395 [details] [diff] [review]
Part 1 - gecko patch - v2

Review of attachment 8348395 [details] [diff] [review]:
-----------------------------------------------------------------

::: b2g/app/b2g.js
@@ +259,5 @@
>  
>  // Layers Acceleration.  We can only have nice things on gonk, because
>  // they're not maintained anywhere else.
>  pref("layers.offmainthreadcomposition.enabled", true);
> +pref("layers.composer2d.enabled", true);

I guess this should be one line lower since it doesn't make sense without Gonk. If not, it should be separate from the comment above.
Attachment #8348395 - Flags: review?(ncameron) → review+
(Assignee)

Updated

4 years ago
Blocks: 942267
Status: NEW → ASSIGNED
blocking-b2g: --- → 1.3?
(Assignee)

Comment 9

4 years ago
Created attachment 8348863 [details] [diff] [review]
Part 1 - gecko patch - v3

Address nrc nit and carry forward r+
Attachment #8348395 - Attachment is obsolete: true
Attachment #8348863 - Flags: review+
(Assignee)

Comment 10

4 years ago
(In reply to Nick Cameron [:nrc] from comment #7)
> Comment on attachment 8348210 [details] [review]
> Part 2 - gaia pull request
> 
> I'm not really sure how to review this. I assume the gaia part will get a
> review on Github, so not sure what needs doing here.

I'll find a gaia reviewer.
(Assignee)

Comment 11

4 years ago
Comment on attachment 8348210 [details] [review]
Part 2 - gaia pull request

Hi kaze,

Can you please review this new developer setting? If not, can you suggest a reviewer?
Attachment #8348210 - Flags: review?(kaze)
Comment on attachment 8348210 [details] [review]
Part 2 - gaia pull request

Missing l10n entry. Please r?-me again when you’re ready.
Attachment #8348210 - Flags: review?(kaze)
(Assignee)

Comment 13

4 years ago
Comment on attachment 8348210 [details] [review]
Part 2 - gaia pull request

Hi kaze,

I updated the PR to address your comment. Please take a new look.
Attachment #8348210 - Flags: review?(kaze)
Comment on attachment 8348210 [details] [review]
Part 2 - gaia pull request

Thanks Diego. :)
Attachment #8348210 - Flags: review?(kaze) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Merged on master:
https://github.com/mozilla-b2g/gaia/commit/5aff5fbf73f6340adcef67f8984f7ad28a32ef90
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
https://hg.mozilla.org/integration/b2g-inbound/rev/d20f05508b0c
https://hg.mozilla.org/mozilla-central/rev/d20f05508b0c
(Assignee)

Comment 18

4 years ago
I think this should be pulled to v1.3 because it will speed up HWC debugging, which still has some have development left in v1.3.
Flags: needinfo?(mvines)
(In reply to Diego Wilson [:diego] from comment #18)
> I think this should be pulled to v1.3 because it will speed up HWC
> debugging, which still has some have development left in v1.3.

Not sure the cut-off for the v1.3 l10n work, and I see a new string here.
Flags: needinfo?(mvines)
status-b2g-v1.3: --- → affected
status-firefox29: --- → fixed
Target Milestone: --- → mozilla29
(Assignee)

Comment 20

4 years ago
kaze,

Do you know if the new setting label needs to be localized to all supported languages in order to merge it to v1.3?
Flags: needinfo?(kaze)
CS blocker, so blocking+
blocking-b2g: 1.3? → 1.3+
Uplifted 5aff5fbf73f6340adcef67f8984f7ad28a32ef90 to:
v1.3: 65448c26e11679334cc5ad10101211197cdf7d50
status-b2g-v1.3: affected → fixed
(Assignee)

Comment 23

4 years ago
Hi John,

Could you also uplift the gecko part to 1.3 please?

See comment 17.
Flags: needinfo?(jhford)
(Assignee)

Updated

4 years ago
status-b2g-v1.3: fixed → affected
Ryan, mind taking a look at the uplift for this?
Flags: needinfo?(jhford) → needinfo?(ryanvm)
It'll show up under my regular queries now that the status is back to affected.
Flags: needinfo?(ryanvm)
https://hg.mozilla.org/releases/mozilla-aurora/rev/00745445ecaa
status-b2g-v1.3: affected → fixed
status-firefox27: --- → wontfix
status-firefox28: --- → fixed
Depends on: 958460

Updated

4 years ago
No longer depends on: 958460

Updated

4 years ago
Depends on: 947504
(In reply to Diego Wilson [:diego] from comment #20)
> Do you know if the new setting label needs to be localized to all supported
> languages in order to merge it to v1.3?

It works the other way round: if we merge it to v1.3, our l10n contributors will get two new strings to translate for this branch.
Flags: needinfo?(kaze)
Duplicate of this bug: 909205
status-b2g-v1.3T: --- → fixed
status-b2g-v1.4: --- → fixed

Updated

4 years ago
Flags: in-moztrap-
You need to log in before you can comment on or make changes to this bug.