Closed Bug 950827 Opened 6 years ago Closed 6 years ago

[B2G][SMS] The Compose Message screen is displayed too low when launching the Message app from Contacts

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox29 affected, b2g-v1.3 unaffected)

RESOLVED DUPLICATE of bug 948875
Tracking Status
firefox29 --- affected
b2g-v1.3 --- unaffected

People

(Reporter: mvaughan, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Description:
If the user launches the Message app from a contact details screen, the Compose Message page is displayed too low. Therefore it shows the top of the contact details screen behind it. 

Prerequisites:
Have at least one contact with a phone number stored on the phone.

Repro Steps:
1) Update Buri to Master M-C (1.4) BuildID: 20131216040201
2) Launch the Contacts app
3) Select a contact
4) Tap the "New text message" icon (speech bubble with quotes inside)

Actual:
Compose message screen is too low, showing part of the screen behind it.

Expected:
Compose message screen is displayed without showing any screens behind it.

Environmental Variables:
Device: Buri Master M-C (1.4) MOZ RIL
BuildID: 20131216040201
Gaia: 358cd74fd2b2ef5d541f71a5d53d65d6a7335424
Gecko: f67feb33a974
Version: 29.0a1
Firmware Version: 20131115

Notes:
Repro frequency: 3/3 100%
See attached: SMSScreen.png

This issue does NOT reproduce on the Buri 12/16 1.3 MOZ RIL build.
This issue started reproducing on the 12/11 Master M-C (1.4) build.

- Works -
Environmental Variables:
Device: Buri 1.4 MOZ RIL
BuildID: 20131210040206
Gaia: c952e2756c03eceb4de6a3eba15651741a62f9e8
Gecko: df82be9d89a5
Version: 29.0a1
Firmware Version: 20131115

- Broken -
Environmental Variables:
Device: Buri 1.4 MOZ RIL
BuildID: 20131211040203
Gaia: 6415b8b44068596404c10365394544e94edd5ce5
Gecko: 12ea03a70243
Version: 29.0a1
Firmware Version: 20131115
blocking-b2g: --- → 1.4?
Assignee: nobody → pivanov
Looks like a regression from the WindowManager work.

We can clearly see the animation starts too low.

Reseting the assignee as it's not a visual bug.
Assignee: pivanov → nobody
Component: Gaia::SMS → Gaia::System
Flags: needinfo?(alive)
Bug 907013 is in the Gaia regression range.
Should be another dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=948875
(Contact app shouldn't be fullscreen)
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(alive)
Resolution: --- → DUPLICATE
Duplicate of bug: 948875
Component: Gaia::System → Gaia::System::Window Mgmt
blocking-b2g: 1.4? → ---
You need to log in before you can comment on or make changes to this bug.