Closed Bug 948875 Opened 6 years ago Closed 6 years ago

[Window Management] Contact/Phone are fullscreen but they shouldn't be.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

RESOLVED FIXED
1.3 C2/1.4 S2(17jan)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: alive, Assigned: alive)

References

Details

Attachments

(1 file)

I guess it's because of entry point problem but not sure.
I saw this once but couldn't get it to reproduce...
Reproduced.
Assignee: nobody → alive
This occurs intermittently...really strange.
The root cause is browse config helper modify the manifest of same copy. So if you run FTU before launching contact/dialer you would have fullscreen them. Stupid fail.
Attachment #8348647 - Flags: review?(timdream)
Duplicate of this bug: 950890
(In reply to Alive Kuo [:alive][NEEDINFO][OOO:12/24-1/4] from comment #4)
> Created attachment 8348647 [details] [review]
> https://github.com/mozilla-b2g/gaia/pull/14749
> 
> The root cause is browse config helper modify the manifest of same copy. So
> if you run FTU before launching contact/dialer you would have fullscreen
> them. Stupid fail.

But nice catch :)
Glad to see this fixed.
Comment on attachment 8348647 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/14749

The patch is acceptable but please consider my proposal in
https://github.com/mozilla-b2g/gaia/pull/14749/files#r8424980

If you rewrite your patch based on that please request for re-review.
Attachment #8348647 - Flags: review?(timdream) → review+
According to bug 950182 this happens on 1.3 branch as well.
blocking-b2g: --- → 1.3?
Comment on attachment 8348647 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/14749

Hello native clone
Attachment #8348647 - Flags: review+ → review?(timdream)
Duplicate of this bug: 950827
Comment on attachment 8348647 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/14749

Deep copy only when entry point case.
Attachment #8348647 - Flags: review+ → review?(timdream)
Comment on attachment 8348647 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/14749

Nasty but seems to be the safest way of doing thing. Please document what config.manifest really is, somewhere.
Attachment #8348647 - Flags: review?(timdream) → review+
https://github.com/mozilla-b2g/gaia/commit/24f392914a46c7de8ec3f33d4da0c35a2133c3e9
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
triage: 1.3+
blocking-b2g: 1.3? → 1.3+
Duplicate of this bug: 950182
Uplifted 24f392914a46c7de8ec3f33d4da0c35a2133c3e9 to:
v1.3: ddcabad6962304b1224b7392697c2857dd76b4a7
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
You need to log in before you can comment on or make changes to this bug.