The requested displayport is sometimes wider than the page

RESOLVED FIXED in Firefox 28

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kats, Assigned: kats)

Tracking

({regression})

unspecified
mozilla29
All
Gonk (Firefox OS)
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox27 unaffected, firefox28 fixed, firefox29 fixed, b2g-v1.2 unaffected, b2g-v1.3 fixed)

Details

(Whiteboard: [beta28] p=0)

Attachments

(1 attachment)

Doing some rendertrace logging on the peak in the settings app showed that the displayport being requested was sometimes 540 pixels wide even though the page was only 360 pixels wide.

Turns out GetExpandedScrollableRect doesn't bother to convert the composition bounds from a ScreenRect to a CSSRect. The composition bounds isn't always correct (bug 935219) but even so expanding the scrollable rect by a ScreenRect composition bounds is wrong.
Created attachment 8348953 [details] [diff] [review]
Patch

This fixes the issue, but I need to test it more to ensure there aren't any other bad side-effects.
Assignee: nobody → bugmail.mozilla
https://hg.mozilla.org/integration/b2g-inbound/rev/e1b8a4d97075

Requesting uplift to 1.3. There are no user-visible bad effects from this bug, but I suspect it might result in wasted memory usage because the displayport is larger than it should be. I'm not actually sure if the texture that gets created is larger or not though.
blocking-b2g: --- → 1.3?
Doh. This is actually a regression introduced very recently in bug 949404.
Blocks: 949404
No longer blocks: 907179
status-b2g-v1.2: --- → unaffected
status-b2g-v1.3: --- → affected
status-firefox27: --- → unaffected
status-firefox28: --- → affected
status-firefox29: --- → affected
Keywords: regression

Updated

5 years ago
Duplicate of this bug: 951751

Updated

5 years ago
Whiteboard: [beta28]
Blocks: 838081
Whiteboard: [beta28] → [beta28] p=0
https://hg.mozilla.org/mozilla-central/rev/e1b8a4d97075
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Blocks: 947326
No longer blocks: 838081
status-firefox29: affected → fixed
Comment on attachment 8348953 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 949404
User impact if declined: panning around on some pages is very janky in metrofox (see bug 951751)
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): low risk, very obvious fix for the regression. affects only b2g and metro
String or IDL/UUID changes made by this patch: none
Attachment #8348953 - Flags: approval-mozilla-aurora?
Attachment #8348953 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/dbdd87455003
status-b2g-v1.3: affected → fixed
status-firefox28: affected → fixed
Already in 1.3 per comment 7, so clearing nom.
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.