No way to trigger "hover" styles (e.g. drop down menus) with touch

RESOLVED WONTFIX

Status

()

defect
P4
normal
RESOLVED WONTFIX
5 years ago
11 months ago

People

(Reporter: krudnitski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=0)

(Reporter)

Description

5 years ago
On my surface pro 2. Go to http://www.marksandspencer.com/ in tablet form (keyboard flipped back).

I tap on 'Christmas' and a drop-down menu for navigation pops up momentarily, but then disappears - doesn't let me interact with it. Instead it just goes to that URL. 

(same for johnlewis.com)

When you use the mouse on the keyboard, you hover and can see the drop-down menu.

Going over to IE Touch, even with the keyboard flipped back, they allow the dropdown visible and interactable, without just going straight to that category. We should try doing the same. (It's not FLAWLESS, but you are, indeed, able to see the drop-down with some light / fancy touching ;) - we can no doubt do better)
This is a problem with any page that relies on mouse hover; adjusting the description to be more general.  See also bug 719690 (similar bug for Firefox for Android).
See Also: → 719690
Summary: 'drop down' menu disappears before being able to interact with it on M&S website → No way to trigger "hover" styles (e.g. drop down menus) with touch
Whiteboard: [triage] → [triage] [defect] p=0
Assignee: nobody → jmathies
Blocks: metrobacklog
No longer blocks: metrov1backlog
Whiteboard: [triage] [defect] p=0 → [defect] p=0
Assignee: jmathies → nobody
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 904932
No longer blocks: metrobacklog
Whiteboard: [defect] p=0
Oops, these are not actually duplicates.

Bug 904932 is about being able to show hover text (i.e. when a user hovers the mouse over a link with alt text, we should be able to show the text somehow).

This bug is about being able to trigger the hover style when using touch input (i.e. when a user is using touch input, there should be some way to do the equivalent of "hovering the mouse over a link")
Blocks: metrobacklog
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [defect] p=0
Status: REOPENED → NEW
No longer blocks: metrobacklog
Component: General → General
Product: Firefox for Metro → Core
Whiteboard: [defect] p=0
Version: 29 Branch → unspecified
Priority: -- → P4
Whiteboard: p=0

Comment 4

4 years ago
Actually, on 41.0.2, firefox does apply hover styles (including opening a cascading menu) when tapping on an element. 

However, the problem is elements that have *both* a click and a hover behavior, such as cascading menus which open when you hover with the mouse over them, but where the anchor element can *also* be clicked directly (lots of menus on Joomla sites, including the Joomla administrator, are done like that)

When you tap on such an event, the click behavior (i.e. follow the link) is invoked directly (popping up the menu).

Firefox could use one of the following approaches to handle this:
1. If an element has both a :hover style and click behavior, apply the :hover style on first tap, and click behavior on second tap (i.e. only if all :hover styles are already activated). Maybe this could be implemented by saying that a tap that changes the appearance of a site is "consumed", and thus no longer available to trigger a link?

2. Or, do as the browser on Ubuntu Touch does it, or even Android's builtin browser: long-tap + cancel leaves hover state activated, but without following link.


Another unpleasant behavior of touch-enabled Firefox is that the "capture area" around links is rather large, so even a tap on an area which is not a link, but merely *next* to a link activates the link instead. So even if the web site tries to accommodate touch users by having a slightly larger hover area than the link area, this doesn't really help Firefox users.
We never shipped the metro support, closing!
Status: NEW → RESOLVED
Last Resolved: 5 years ago11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.