"DebuggerServer is not defined" {file: "resource://gre/modules/devtools/server/child.js"

RESOLVED FIXED in Firefox 29

Status

()

Firefox
Developer Tools: WebIDE
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: paul, Assigned: paul)

Tracking

Trunk
Firefox 29
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs-coverage])

Attachments

(1 attachment, 1 obsolete attachment)

980 bytes, patch
ochameau
: review+
Details | Diff | Splinter Review
Comment hidden (empty)
(Assignee)

Comment 1

4 years ago
Created attachment 8349335 [details] [diff] [review]
v1
Assignee: nobody → paul
Status: NEW → ASSIGNED
Attachment #8349335 - Flags: review?(poirot.alex)
(Assignee)

Comment 2

4 years ago
Created attachment 8349336 [details] [diff] [review]
v1.1
Attachment #8349335 - Attachment is obsolete: true
Attachment #8349335 - Flags: review?(poirot.alex)
Attachment #8349336 - Flags: review?(poirot.alex)
Comment on attachment 8349336 [details] [diff] [review]
v1.1

Good for a workaround, but we should figure out the original issue,
I'm going to verify if it is due to bug 673569.
That's quite impressive if child.js is the only one suffering from such regression!
Attachment #8349336 - Flags: review?(poirot.alex) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/34e88cb414cd
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
Paul, did you see this issue with the 2013-12-18 Keon nightly?  I was hoping to reproduce this for my own testing of other server changes, but I am able to connect and debug an app successfully.

What version did you use and what steps did you perform?
Flags: needinfo?(paul)
Never mind, I misread timestamps.  Looks like bug 673569 is not yet in the Keon nightlies.
Flags: needinfo?(paul)
https://hg.mozilla.org/mozilla-central/rev/34e88cb414cd
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29
Whiteboard: [needs-coverage]
You need to log in before you can comment on or make changes to this bug.