If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[camera] During camcorder recording, Voice call ringtone gets recorded while receiving call

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Camera
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Inder, Assigned: slee)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [CR 587557])

(Reporter)

Description

4 years ago
Steps to Reproduce:
1. Open camera and switch to camcorder.
2. Start video recording
3. Make a voice call to the device and receive the call.
4. Hang up the call
5. Play the recording from gallery

Observation:
  Voice call ringtone get encode in the recorded clip.

Expected:
  Camcorder should stop recording first then voice call ringtone decode should start.

Build: Observed in both v1.2 and v1.3
Device: QRD
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 1.3?
Media Triage requests testing on Buri.
Flags: needinfo?(mozillamarcia.knous)
Tested with Buri using:

Gaia   a99249a7fdf9f20850d98a9a222385676d472362
SourceStamp 809aabadac6d
BuildID 20131219004002
Version 28.0a2

Unable to reproduce the issue.
Flags: needinfo?(mozillamarcia.knous)
(Reporter)

Comment 3

4 years ago
:marcia -- can you try reproducing it on unagi. As per this comment: https://bugzilla.mozilla.org/show_bug.cgi?id=951410#c7 marco has been able to reproduce similar MM issues on unagi.
(Reporter)

Comment 4

4 years ago
Build info:
v1.3
gecko: 6212fb5be0b20e1776041f653eeb036e4557aa8b
gaia: a99249a7fdf9f20850d98a9a222385676d472362

v1.2
gecko: 65dfa0844f0abbe4cfc90708f8620df4811afe6a
gaia: c82c957e9d4078cd4043de6b7d21a2667a73adf7

Comment 5

4 years ago
NI CJ/Marco to see if their team can help with this media recording issue
Flags: needinfo?(cku)
Steven, please help to fix this issue.
Assignee: nobody → slee
Flags: needinfo?(cku)

Comment 7

4 years ago
1/9 triage update: While the steps and issue that Inder is seeing is not the expected behavior, we are unable to reproduce it on any of production devices. I will leave this in 1.3? until we are able to reproduce.
(Assignee)

Comment 8

4 years ago
I cannot reproduce the problem on unagi with today's m-c and gonk.
Not possible to reproduce per comment 2, comment 7, comment 8, so not blocking.
blocking-b2g: 1.3? → -
Whiteboard: [CR 587557] → [CR 587557][closeme 1/16/2014]

Comment 10

4 years ago
Resolved per whiteboard
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Whiteboard: [CR 587557][closeme 1/16/2014] → [CR 587557]

Updated

3 years ago
See Also: → bug 1145554
You need to log in before you can comment on or make changes to this bug.