Portions of window obscured by black or white box

RESOLVED INCOMPLETE

Status

()

--
major
RESOLVED INCOMPLETE
5 years ago
3 years ago

People

(Reporter: essin, Assigned: bas.schouten)

Tracking

26 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

102.42 KB, application/x-zip-compressed
Details
(Reporter)

Description

5 years ago
Created attachment 8349710 [details]
Firefox errors.zip

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

Visit a web page and scroll up and down

Win 8.1, 64-bit machine, 8 GIG ram


Actual results:

a black (sometimes white) rectangle is drawn on the screen obscuring part of the page. It goes away when scrolling some more and then reappears later. It's happening now, as I type.


Expected results:

no box
(Reporter)

Updated

5 years ago
Severity: normal → major
I see that you have lots of add-ons. Could you please try the following, to see if you still reproduce the issue:

1) running in Safe mode:
http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

2) try this with a clean profile:
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(essin)
(Reporter)

Comment 2

5 years ago
This problem seems to be related to hardware acceleration on win 8.1 64-bit. I experience the problem on two machines and turning off hardware accel in the advanced tab seems to eliminate thew problem. I think I should test this longer before fiddling with profiles.
Flags: needinfo?(essin)
Related to bug 975555 and bug 988862?
I have the same problem on Windows 7 64bit.
Alessio, can you send the about:support graphics section?  In particular, what is the value for the AzureContentBackend entry?
Flags: needinfo?(alessio.placitelli)
Milan, the following are the values in about:support graphics section (AzureContentBackend -> direct2d). Is there anything else I can do to help?

Data aggiornamento driver	10-16-2014
Descrizione scheda grafica	NVIDIA GeForce GTX 560 Ti
Direct2D attivo	true
DirectWrite attivo	true (6.2.9200.16492)
Driver scheda grafica	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Finestre con accelerazione GPU	1/1 Direct3D 11 (OMTC)
GPU #2 attiva	false
ID dispositivo	0x1200
ID produttore	0x10de
RAM scheda grafica	1024
Rendering WebGL	Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Ti Direct3D9Ex vs_3_0 ps_3_0)
Versione driver	9.18.13.4448
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Flags: needinfo?(alessio.placitelli)
Thanks Alessio, I'll leave it to Bas now to ask for more information.  I just wanted to see if you're getting the D2D 1.1, but it looks like you're not.
Assignee: nobody → bas

Comment 8

4 years ago
I am seeing the same issue in Mac OS 10.8.5 running Firefox 35.0.1 (only black boxes; not white ones) -- See Bug 1130385 

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805
Hi Daniel,

I wasn't able to reproduce this issue on the latest Firefox release(43.0.4) nor the latest Nightly(46.0a1).

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160106030225

Could you please try to reproduce this on the latest release(43.0.4) and latest Nightly (https://nightly.mozilla.org/) and provide the results? When doing this, please try to reproduce with a new clean Firefox profile, maybe even in safe mode, as some of this issues may be caused by third party installed add-ons or custom settings(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).
Flags: needinfo?(essin)
Since the reporter didn't provide the requested information, I will mark this issue as RESOLVED INCOMPLETE. If you still encounter this problem, please feel free to reopen this bug, or file a new one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(essin)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.