Closed Bug 952336 Opened 6 years ago Closed 6 years ago

Switch-to-tab on the current tab does not reshow web content

Categories

(Firefox for Android :: Awesomescreen, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 27
Tracking Status
firefox26 --- verified
firefox27 --- verified
firefox28 --- unaffected
fennec 27+ ---

People

(Reporter: mcomella, Assigned: mcomella)

References

Details

(Keywords: reproducible)

Attachments

(1 file)

Patch #2 in bug 951776 fixes this for 26. This bug is specifically for 27, which should be fixed with a similar patch.
Explicit STR:
1) Go to apple.com
2) Click URL bar, type "apple"
3) Select switch-to-tab
Note to self: write some test cases.
Let's change this to fixed since it landed on the branch.
(In reply to Aaron Train [:aaronmt] from comment #4)
> Let's change this to fixed since it landed on the branch.

via bug 951776.
Test switch-to-tab from the bookmarks/history lists too!
Basically patch #2 from bug 951776. Note this relies on the patch in bug 952343 to work (only due to the added comment though).
Attachment #8350414 - Flags: review?(sriram)
Marked blocking for the dependency mentioned in comment 7.
Blocks: 952343
tracking-fennec: --- → 27+
No longer blocks: 952343
Depends on: 952343
Attachment #8350414 - Flags: review?(sriram) → review+
Comment on attachment 8350414 [details] [diff] [review]
Switch-to-tab on the current tab properly reshows web content.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Unknown.

User impact if declined: 
  Hitting switch-to-tab from a page to itself will not return to the web content properly.

Testing completed (on m-c, etc.):
  Similar patch into release yesterday (bug 951776), similar patches on 28 and 29 for at least a month
 
Risk to taking this patch (and alternatives if risky):
  Medium, since we're playing with changing the visibility of essential views, in the worst case, this bricks the browser until a force stop. However, this patch is similar to those we done before and so I'm confident it will not be all that problematic.
 
String or IDL/UUID changes made by this patch:
  None

Note that bug 952343 needs to be uplifted first.
Attachment #8350414 - Flags: approval-mozilla-beta?
Keywords: reproducible
Keywords: verifyme
Attachment #8350414 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/82b238f279dd
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Verified as fixed in builds:
- 26;
- 27 beta 6; 
Device: Google Nexus 7 (Android 4.4.2);
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.