Closed Bug 952592 Opened 6 years ago Closed 6 years ago

Collect sizemode from first window in BrowserUITelemetry

Categories

(Firefox :: Toolbars and Customization, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29
Tracking Status
firefox27 --- fixed
firefox28 --- fixed
firefox29 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

Details

(Whiteboard: [Australis:P-][fixed-in-holly][qa-])

Attachments

(2 files, 3 obsolete files)

UX wants to know whether or not users tend to have browser windows that are maximized.

We're a little limited, because we only sample one window (the first non-popup browser window). But that will hopefully give us enough information to think about.
Attached patch Patch v1 - for non-Australis (obsolete) — Splinter Review
Attachment #8350739 - Attachment is obsolete: true
Putting in a more helpful comment.
Attachment #8350740 - Attachment is obsolete: true
Attachment #8350746 - Flags: review?(gijskruitbosch+bugs)
Attachment #8350748 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8350746 [details] [diff] [review]
Patch v1 - for Australis

Review of attachment 8350746 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, assuming we've checked this is called after sessionrestore has run, so we don't have the same problem as with the number of tabs (which I saw fly by in emails and assume is related to when we're measuring...)
Attachment #8350746 - Flags: review?(gijskruitbosch+bugs) → review+
Comment on attachment 8350748 [details] [diff] [review]
Patch v1.1 - for non-Australis

Review of attachment 8350748 [details] [diff] [review]:
-----------------------------------------------------------------

Ditto.
Attachment #8350748 - Flags: review?(gijskruitbosch+bugs) → review+
With bug 956138 landed, we'll gather this after sessionrestore has loaded. Thanks!
Landed on Holly as https://hg.mozilla.org/projects/holly/rev/584c5d89dac0
Whiteboard: [Australis:P-] → [Australis:P-][fixed-in-holly]
Comment on attachment 8350748 [details] [diff] [review]
Patch v1.1 - for non-Australis

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 

None. This allows BrowserUITelemetry to record the sizemode of the browser window after start-up.


User impact if declined: 

None.


Testing completed (on m-c, etc.): 

Just local testing.


Risk to taking this patch (and alternatives if risky): 

Very low.


String or IDL/UUID changes made by this patch:

None.
Attachment #8350748 - Flags: approval-mozilla-beta?
Attachment #8350748 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/2acfc7a8756e
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Attachment #8350748 - Flags: approval-mozilla-beta?
Attachment #8350748 - Flags: approval-mozilla-beta+
Attachment #8350748 - Flags: approval-mozilla-aurora?
Attachment #8350748 - Flags: approval-mozilla-aurora+
Whiteboard: [Australis:P-][fixed-in-holly] → [Australis:P-][fixed-in-holly][q-a]
Whiteboard: [Australis:P-][fixed-in-holly][q-a] → [Australis:P-][fixed-in-holly][qa-]
You need to log in before you can comment on or make changes to this bug.