Create keyboarding overlay for one-handed typists

RESOLVED WONTFIX

Status

()

Core
Keyboard: Navigation
P3
normal
RESOLVED WONTFIX
17 years ago
14 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Aaron Leventhal)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
spun off from bug 55759:

From Aaron Leventhal 2001-08-09 18:57:

If we do this eventually, I suggest we create a keyboard configuration file for
one-handed keyboard use in general. Such an overlay would make all the browser
features more convenient, by utilizing unmodified alphanumeric keys the way
Opera and Lynx do.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.3

Comment 1

17 years ago
moving from 0.9.3 -> 0.9.5 since 0.9.4 is out the door.

Updated

17 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.5
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.5 → Future

Updated

17 years ago
Whiteboard: [Aufbau-P5]

Updated

16 years ago
Whiteboard: [Aufbau-P5]

Comment 2

16 years ago
*** Bug 108972 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
*** Bug 141580 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

16 years ago
*** Bug 162360 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
Why make this a separate overlay? Can't we just make the single-key shortcuts
part of the default keybinding?
(Assignee)

Comment 6

16 years ago
Two reasons not to, that I can see:
1. auto type ahead find, in bug 30088 would conflict with it
2. shortcuts that leave the page would cause data loss when users thought they
were about to type into a form

Comment 7

15 years ago
I vote for NOT doing this, too. Most user-friendly desktops, such as Gnome, 
Windows, has already provided the "sticky keys" function that enable to perform 
multiple simultaneous keypress by pressing the keys in sequence. So that would 
no longer be a problem for the one-handed typists.

Comment 8

14 years ago
Install a mouse-gesture extension and then you can surf one handed.  
(Assignee)

Comment 9

14 years ago
(In reply to comment #7)
> I vote for NOT doing this, too. Most user-friendly desktops, such as Gnome, 
> Windows, has already provided the "sticky keys" function that enable to perform 
> multiple simultaneous keypress by pressing the keys in sequence. So that would 
> no longer be a problem for the one-handed typists.

I agree.

If someone wants to come up with a convenient keystroke browsing extension,
that's fine. I suggest they start a project on mozdev.org to do it.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.