Closed Bug 953150 Opened 8 years ago Closed 8 years ago

[DSDS] Unable to Reset PIN2 from FDN menu

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

RESOLVED FIXED
1.3 C2/1.4 S2(17jan)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: poojas, Assigned: kaze)

References

()

Details

(Keywords: regression, Whiteboard: [CR 592872])

Attachments

(2 files)

191 bytes, text/html
kaze
: review-
Details
46 bytes, text/x-github-pull-request
arthurcc
: review+
Details | Review
User Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.24) Gecko/20111107 Ubuntu/10.04 (lucid) Firefox/3.6.24 (Nightly/Aurora)
Build ID: 20111107172717

Steps to reproduce:

Go to Settings -> Call Settings -> Select a SIM Card -> Fixed dialing number -> Reset PIN2


Actual results:

No activity  after clicking "Reset PIN2" button
In adb logs, it shows below error

E/GeckoConsole( 1150): [JavaScript Error: "TypeError: options is undefined" {file: "app://settings.gaiamobile.org/js/simcard_dialog.js" line: 402}]


Expected results:

After clicking reset button, it should have shown "Reset PIN2" window. And take input to change PIN2.  

In bug 921971 and bug 947907, its mentioned that fdn pin2 will work for both the sims appropriately from 1.4.

But due to this bug, reset pin2 is not working even for single sim.
Attached file pr.html
Attached patch fixes this issue.
Please review
Attachment #8351482 - Flags: review?(kaze)
Attachment #8351482 - Flags: review?(ehung)
Whiteboard: [CR 592872]
Status: UNCONFIRMED → ASSIGNED
blocking-b2g: --- → 1.3+
Ever confirmed: true
No longer depends on: 953159
Hi kaze and ehung,

Please provide feedback on this.
Keywords: regression
Keywords: regression
Fabien, did you get a chance to review the fix for this bug?
Flags: needinfo?(kaze)
Comment on attachment 8351482 [details]
pr.html

Redirect to Arthur, since he knows more on SIM2 and FDN.
Attachment #8351482 - Flags: review?(ehung) → review?(arthur.chen)
Assignee: nobody → poojas
Comment on attachment 8351482 [details]
pr.html

OMG, good catch!
Attachment #8351482 - Flags: review?(kaze)
Attachment #8351482 - Flags: review?(arthur.chen)
Attachment #8351482 - Flags: review+
Flags: needinfo?(kaze)
Hmm, looks like I’ve merged this too fast. It’s a regression of bug 928295: the `options' argument of the `show()' method was optional, but the patch provided for bug 928295 made it mandatory.
Back-out: https://github.com/mozilla-b2g/gaia/commit/beb7180

Stealing.
Assignee: poojas → kaze
Depends on: 928295
Keywords: regression
Attachment #8351482 - Flags: review+ → review-
Attached file patch
Attachment #8357151 - Flags: review?(arthur.chen)
Duplicate of this bug: 957612
Arthur,

Please help provide your input on the review at the earliest.
Flags: needinfo?(arthur.chen)
Comment on attachment 8357151 [details] [review]
patch

r=me. Thanks!
Attachment #8357151 - Flags: review?(arthur.chen) → review+
Flags: needinfo?(arthur.chen)
master: 8abf6df115305809c8b1e79e62834fb0a5b4c3aa
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Uplifted 8abf6df115305809c8b1e79e62834fb0a5b4c3aa to:
v1.3: dc36d5dbf966891bfdbbfd9821f07aafbf484a38
Flags: in-testsuite?
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
Flags: in-moztrap?
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.