Closed Bug 953253 Opened 6 years ago Closed 6 years ago

overflow:hidden issue on Firefox 26 on Windows 7

Categories

(Core :: Graphics, defect)

26 Branch
x86_64
Windows 8
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 953334
Tracking Status
firefox26 --- affected
firefox27 + fixed
firefox-esr17 --- unaffected
firefox-esr24 --- unaffected

People

(Reporter: miika.langille, Assigned: jrmuizel)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

Consider the following jsFiddle: http://jsfiddle.net/2DF8w/4/
If you open it in Firefox 26 on Windows 7 SP1, then the text inside the treeview breaks out of the overflow:hidden container. Older versions of Firefox, or then on Windows 8, it works just fine. No other browser reproduces this issue.

Note that the results pane needs to be expanded to make the treeview visible. More details can be found on this stackoverflow post: http://stackoverflow.com/questions/20798690/overflowhidden-bug-in-firefox26-on-windows-7


Actual results:

The text of the treeview breaks outside of the container.


Expected results:

The overflowing text should be hidden.
WFM 
http://hg.mozilla.org/releases/mozilla-release/rev/39faf812aaec
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20131205075310
WFM with FF26 on Win 7.
Could you test with a clean profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(miika.langille)
Please load about:support and post the Graphics section from that page.
Flags: needinfo?(miika.langille)
Flags: needinfo?(miika.langille)
Unfortunately the support page is in finnish, but everything should be in the right place.
Flags: needinfo?(miika.langille)
I can repro.
user_pref("gfx.content.azure.backends", "");
user_pref("layers.prefer-d3d9", true);

http://hg.mozilla.org/releases/mozilla-beta/rev/5a11c57ceaa7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131216183647
Blocks: 904266
Status: UNCONFIRMED → NEW
Component: Untriaged → Graphics
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
No longer blocks: 904266
Sorry, this is my first time reporting a Firefox bug. Alice, are you saying you you've been able to confirm this as a bug?
Flags: needinfo?(alice0775)
1st, you should try with clean profile.
Flags: needinfo?(alice0775)
Regression wijndow(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/365e150efda0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130904135414
Bad;
http://hg.mozilla.org/integration/mozilla-inbound/rev/b5d62f5c733c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130904135614
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=365e150efda0&tochange=b5d62f5c733c
Regressed by: 
b5d62f5c733c	Benoit Girard — Bug 907544 - Pass the D3DSurface9 down into Cairo for LockRect. r=jrmuizel
Thanks! we'll take a look next week.
Tracking as this is a recent regression and passing it to :Benwa given its possibly a fallout from 907544.
Assignee: nobody → bgirard
I can't seem to expand the results pane. Is the fiddle broken?
(In reply to Jeff Muizelaar [:jrmuizel] from comment #11)
> I can't seem to expand the results pane. Is the fiddle broken?

Right click on results pane and select "This Frame" > "Show Only This Frame"
Attached image out.png
All that I see is what I've attached. No "This Frame"
(In reply to Jeff Muizelaar [:jrmuizel] from comment #13)
> Created attachment 8356257 [details]
> out.png
> 
> All that I see is what I've attached. No "This Frame"

Right mouse button click on the right-bottom pane in order to pop up browser's context menu.
Then, select "This Frame" > "Show Only This Frame"
Duplicate of this bug: 953334
Does this bug still occur now that bug 953334 is fixed?
Flags: needinfo?(alice0775)
(In reply to Mats Palmgren (:mats) from comment #16)
> Does this bug still occur now that bug 953334 is fixed?

bug 953334 is not landed Firefox27.
So, I cannot test.
Flags: needinfo?(alice0775)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 953334
Assignee: bgirard → jmuizelaar
Marking this fixed on Firefox 27 given 953334 was uplifted. Please re-open if this is still unresolved for you
You need to log in before you can comment on or make changes to this bug.