XMPP: detect if user-id contains domain

RESOLVED INVALID

Status

Instantbird
Account wizard
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: Instantbot, Unassigned)

Tracking

Dependency tree / graph

Details

(Reporter)

Description

5 years ago
*** Original post on bio 432 by John Doe <buggy AT mailinator.com> at 2010-07-03 11:43:00 UTC ***

As the JID (Jabber ID) is defined to be of the format user@domain.tld, I entered a complete JID in the username field. This resulted in a duplicate domain: user@domain.tld@domain.tld, which of course is invalid.

Instantbird could be smarter and detect if the entered username contains an @ sign. If the domain part matches the Domain field, strip it, otherwise complain.

Or it could just not allow @ signs in the Username field. Hitting the @ key in Username could trigger focussing the Domain field.
*** Original post on bio 432 at 2010-07-03 22:59:47 UTC ***

I like the @-key idea. Let's see.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
*** Original post on bio 432 at 2010-07-04 00:08:56 UTC ***

(In reply to comment #1)
> I like the @-key idea. Let's see.

I love it too. Having the separator character used to change the focus to the next field was something I wanted to have when we split the username field in several parts.

I think we didn't do it because the '@' can be valid inside the "user" part of an XMPP id. If I remember well, it's possible to use any email address with google talk, and the XMPP id becomes <email>@gmail.com, where "email" contains the '@' character.
I'm not sure of this. Someone or something made me believe this at least when we implemented the username split. I would love if it could be proved wrong! :)
*** Original post on bio 432 at 2010-07-04 06:54:30 UTC ***

I think @s are not allowed in the user part of the address. Technically.
Everything seems to be allowed as long as it is percentage-encoded (like on URLs).

So an "@" can be entered as long as it gets converted to it's percentage-encoded equivalent. So far so bad.

Some specs: http://xmpp.org/rfcs/rfc5122.html#use-form
The IRI thing it is pointing to is here: http://tools.ietf.org/html/rfc3987#page-7


Maybe go to the next field by default and add a UI element that allows to undo it (cf Smart tags on MS Office that allow to undo automated actions) ?
(Reporter)

Comment 4

5 years ago
*** Original post on bio 432 by Ludovic Hirlimann <ludovic AT hirlimann.net> at 2011-06-30 09:14:30 UTC ***

This could easily be morphed into removing the default gmail.com domain.

Updated

3 years ago
Blocks: 1139287
Severity: enhancement → normal

Comment 5

2 years ago
Does not apply to JS-XMPP (now default) which has a separate username and domain field in the account wizard.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Updated

2 years ago
Depends on: 955019
You need to log in before you can comment on or make changes to this bug.