Closed Bug 955019 Opened 6 years ago Closed 4 years ago

Replace libpurple XMPP with JS-XMPP

Categories

(Chat Core :: XMPP, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Instantbird 50

People

(Reporter: clokep, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(2 files, 1 obsolete file)

*** Original post on bio 1589 at 2012-07-12 12:42:00 UTC ***

Instead of shipping two sets of XMPP code, it would be great to enable JS-XMPP by default and stop shipping libpurple XMPP. This requires Mozilla Bio 14328 (DNS SRV support) to be fixed first.

Note that the Bonjour code currently uses libpurple XMPP, I'm unsure how that would be affected by this change.

Any regressions between XMPP and JS-XMPP should block this bug.
*** Original post on bio 1589 at 2012-07-12 12:43:48 UTC ***

This is also blocked by https://bugzilla.mozilla.org/show_bug.cgi?id=628312 ("StartTLS hostname issue").
Whiteboard: [1.3-wanted]
Depends on: 954955, 954956, 954957, 954959, 954988
*** Original post on bio 1589 as attmnt 1757 at 2012-07-26 13:23:00 UTC ***

So today Gtalk is down so I need to use generic XMPP accounts for my testing on other JS-XMPP bugs. Here's an attachment that enables JS-XMPP for generic XMPP accounts without removing the existing libpurple plugin.
Depends on: 955039
*** Original post on bio 1589 at 2012-11-02 00:12:45 UTC ***

Too late to work on this for 1.3, replacing 1.3-wanted by 1.4-wanted in the whiteboard.
Whiteboard: [1.3-wanted] → [1.4-wanted]
*** Original post on bio 1589 at 2012-12-14 14:54:59 UTC ***

We also need to fix https://bugzilla.mozilla.org/show_bug.cgi?id=817596 before replacing the libpurple xmpp implementation.
Blocks: 954938
*** Original post on bio 1589 at 2013-04-09 14:50:04 UTC ***

s/1.4-wanted/1.5-wanted/ in the whiteboard for bugs that probably won't happen before 1.4 is released.
Whiteboard: [1.4-wanted] → [1.5-wanted]
Depends on: 955453
Depends on: 955489
*** Original post on bio 1589 as attmnt 2602 at 2013-07-15 20:36:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354371 - Flags: review?(clokep)
Comment on attachment 8353518 [details] [diff] [review]
WIP enabling JS-XMPP for generic XMPP for testing purpose

*** Original change on bio 1589 attmnt 1757 at 2013-07-15 20:36:28 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8353518 - Attachment is obsolete: true
Comment on attachment 8354371 [details] [diff] [review]
Enable JS-XMPP for generic XMPP, but pref'ed off

*** Original change on bio 1589 attmnt 2602 at 2013-07-15 20:56:52 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354371 - Flags: review?(clokep) → review+
*** Original post on bio 1589 at 2013-07-15 21:31:39 UTC ***

I'll leave this bug open since it is still pref'ed off:
http://hg.instantbird.org/instantbird/rev/6ac1e104befc
Whiteboard: [1.5-wanted]
Depends on: 974438
Depends on: 978564
Depends on: 787369
Depends on: 735200
Depends on: 955307
Depends on: 955740
Blocks: 953928
Depends on: 628312
After landing of bug 1171691, Do not forget to remove the pref check [1] for forcePurple when JS-XMPP is enabled.

[1] https://dxr.mozilla.org/comm-central/source/chat/content/imtooltip.xml#230
Depends on: 1205769
(In reply to Abdelrhman Ahmed [:abdelrhman] from comment #10)
> After landing of bug 1171691, Do not forget to remove the pref check [1] for
> forcePurple when JS-XMPP is enabled.

No longer needed.
Bug 955317 would also be nice-to-have, but doesn't block this.
Depends on: 1267649
No longer depends on: 1269331
Depends on: 1277931
Depends on: 1282099
No longer depends on: 1282099
No longer depends on: 1277931
No longer depends on: 735200
Attachment #8770169 - Flags: review?(aleth) → review+
:-)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Instantbird 50
Blocks: 953873
You need to log in before you can comment on or make changes to this bug.