[PP]Copy a news article to a local pop mail folder fails

VERIFIED FIXED in M11

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: pmock, Assigned: jefft)

Tracking

Trunk
All
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PR1])

(Reporter)

Description

19 years ago
Build Date & Platform Bug Found:
  Mac Seamonkey build 1999-07-08-10 installed on PPC 9600/300 Mac OS 8.5.1
  Mac Seamonkey build 1999-07-09-08 installed on PPC 9600/300 Mac OS 8.5.1
  Linux Seamonkey build 1999-07-09-8 installed on Compaq P200 Redhat 5.2
  Win32 Seamonkey build 1999-07-09-10 installed on Gateway P200 Win98

Overview Description:
  The operation to copy a news article to a local mail folder fails.  No message
is copied.  I was using a single pop profile and single news server
configuration.  Exiting and relaunching Apprunner to refresh the message list
does not correct the problem.

Steps to Reproduce:
1) Configure your prefs50.js to have one pop mail account and 1 news server
   I was using news.mozilla.org as my news server
2) Launch Apprunner
3) Open Messenger using the Task menu or through the Component bar
4) Select the news server icon
5) Double click on the server icon to expand the list of newsgroup(s)
6) Select the newsgroup
   Message should be listed in the Thread pane
7) Select a message
   The message contents should display in the message pane
8) Select the Message menu and choose Copy message option
   It will list your mail and news folder list.
9) From your local mail folder list, select a folder to copy the news article to
10) Select the mail server icon
11) Double click on e mail server icon
    A list of pop folder should be displayed
12) Select your local mail folder that you selected as your destination folder
    Notice the folder does not contain the copied message

Actual Results:
  No news article is copied to the local mail folder.

Expected Results:
  The news article should be copied to the desired mail folder.  It should appear
when you open the mail folder.  You should not need to refresh the list of
messages in the thread pane.

Additional Builds and Platforms Tested On:
  See above for builds tested.

Additional Information:
  This problem occurs on all platforms.

Updated

19 years ago
Assignee: phil → sspitzer

Comment 1

19 years ago
I'm not sure that this is supposed to work now.  Reassigning to sspizter and
cc'ing jefft since I'm not sure who is working on this.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M9
(Assignee)

Comment 2

19 years ago
No, this isn't done yet. I need to implement nsNntpService::CopyMessage() in
order to make it work.
Assignee: sspitzer → jefft
Status: ASSIGNED → NEW
re-assign to jefft.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

19 years ago
This is fixed both for Pop3 and Imap4 mail folder.

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 5

19 years ago
Build 1999081308M9: Linux/Redhat 6.0, Mac 8.5.1

Copying from a news folder works but I have to restart the application to see
the message.

Win32: This doesn't happen on Esther's window system.

Updated

19 years ago
Summary: Copy a news article to a local pop mail folder fails → [PP]Copy a news article to a local pop mail folder fails

Comment 6

19 years ago
Setting to [PP] since you need to restart the application in Linux and Mac. The
Windows versions works without restarting.
(Assignee)

Updated

19 years ago
Target Milestone: M9 → M10
(Assignee)

Comment 7

19 years ago
I don't think this is a stopper. And I don't have time to fix this one now. I'm
going on a plane very soon.

Comment 8

19 years ago
Try these two things to see if there is platform parity:

On Windows, delete the .msf file for the POP folder you are copying into and see
if this still works.  My guess is it won't.

On Mac and Linux, click on the folder you are going to copy into before doing
the copy.  Then try the copy.  See if this works.

If following the above leads to the Windows one failing and the Mac and Unix
working, then I'd leave this bug as fixed and recognize that the problem you are
seeing is a dup of 10344.

Updated

19 years ago
Resolution: FIXED → ---

Comment 9

19 years ago
Clearing FIXED resolution due to reopen of this bug.

Comment 10

19 years ago
Esther, when you get a chance, can you try what Scott suggests?

Comment 11

19 years ago
OK, using 19990816 build on win98:
1. I closed Seamonkey
2. I deleted the qatest04.msf file in my User directory.  This is the local
folder in my qatest04 pop account that I copy messages too.
3. I launched Seamonkey
4. Selected netscape.test and selected a message
5. Under Message menu  I selected Copy and chose to copy to my qatest04 pop
account  to folder qatest04.
6. Without closing Seamonkey, I selected the local folder and the message was
there.  The copy worked.  I then did an undo and that worked to.

Comment 12

19 years ago
For linux:
Nbaca opened the target folder and then copied the news msg.
The message was there, without closing and opening again, however only the
Sender was displayed and when we clicked on the message it displayed a Parser
error message in the header.  Only after closing and opening apprunner again did
the message display correctly.
(Reporter)

Comment 13

19 years ago
On today Mac build 1999-08-16-08-m9 build.
 After I copy the news article to a local pop folder, the date and status are
the only two columns that display information on the message.  The subject and
sender columns are blank.  In the message body, it display only a partial
header.  ie  "X-Mozilla-Status: 001X-Mozilla-Status2: 00000000".
 To see the message, I must quit and restart apprunner.  Closing and re-opening
messenger (without restarting appunner) does not help.

Comment 14

19 years ago
OK. My guess was wrong.

Updated

19 years ago
Whiteboard: [PR1]

Comment 15

19 years ago
Sounds like this needs to be fixed for PR1, so I added a note to the Status
Whiteboard

Comment 16

19 years ago
Jeff's on vacation; moving his M10 bugs to M11
(Assignee)

Comment 17

19 years ago
This sounds to me a typical platform line ending problem. We might not handle
carrige return & line feed correctly. Need to look into how we generate the tmp
file.

Updated

19 years ago
Blocks: 11091

Comment 18

19 years ago
(target milestone is M11 or M12 - add to mail beta tracking bug)
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

19 years ago
Fixed checked in. Replacing CRLF with MSG_LINEBREAK. nsLocalMailFolder.cpp
changed.
(Assignee)

Comment 20

19 years ago
*** Bug 15214 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 21

19 years ago
Mac (1999-10-07-08 M11) and Mac (1999-10-06-17 M10)
Copy a news article to a local pop mail folder works fine in both M10 and M11
Mac builds.

Updated

18 years ago
Status: VERIFIED → REOPENED

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 22

18 years ago
Linux (1999-10-26-08 M11)
Win_nt 4.0 (1999-10-26-09 M11)
Copying a news article to a local pop mail folder.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.