QQ - Hangs when trying to get Captcha from server

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
6 years ago
4 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [1.6-wanted])

*** Original post on bio 578 by benjaminjohnson80 AT gmail.com at 2010-11-09 20:58:00 UTC ***

I'm not sure why, but at times the QQ service requires the user to enter what is shown on the Captcha image.  When this occurs with Instantbird, it just hangs there saying Requesting Captcha from server.

I'm not entirely sure how to reproduce...maybe sign in and out a bunch or try to add a few users as buddies within a short timeframe.

Thanks,

Ben
*** Original post on bio 578 at 2010-11-10 08:53:57 UTC ***

Do you know how this captcha is handled and shown by the official client and/or by Pidgin/Adium?
*** Original post on bio 578 by benjaminjohnson80 AT gmail.com at 2010-11-14 02:40:44 UTC ***

(In reply to comment #1)
> Do you know how this captcha is handled and shown by the official client and/or
> by Pidgin/Adium?

I don't believe Adium handles it, but I'm not sure.  The official client pops up the capture image and submits whatever the user enters.

I will probably take a stab at fixing this if no one else has, but probably not for a few weeks.
*** Original post on bio 578 by Matt Lewandowsky (lewellyn) <matt AT greenviolet.net> at 2011-09-06 18:16:26 UTC ***

(In reply to comment #2)
> (In reply to comment #1)
> > Do you know how this captcha is handled and shown by the official client and/or
> > by Pidgin/Adium?
> 
> I don't believe Adium handles it, but I'm not sure.  The official client pops
> up the capture image and submits whatever the user enters.
> 
> I will probably take a stab at fixing this if no one else has, but probably not
> for a few weeks.

This is caused by Tencent discontinuing support for the protocol versions used by libpurple's QQ library, which is no longer supported by them.
Depends on: 954456
*** Original post on bio 578 at 2012-05-08 12:28:49 UTC ***

We don't currently handle libpurple's request API, so we don't pop up the captcha window. I started working on this a bit, but haven't actually gotten anything working. I could point someone to the parts of the code to look at if they're interested in what needs to be done.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [1.3-wanted]
*** Original post on bio 578 at 2012-11-02 00:12:43 UTC ***

Too late to work on this for 1.3, replacing 1.3-wanted by 1.4-wanted in the whiteboard.
Whiteboard: [1.3-wanted] → [1.4-wanted]
*** Original post on bio 578 at 2013-04-09 14:50:00 UTC ***

s/1.4-wanted/1.5-wanted/ in the whiteboard for bugs that probably won't happen before 1.4 is released.
Whiteboard: [1.4-wanted] → [1.5-wanted]
*** Original post on bio 578 at 2013-11-02 17:41:55 UTC ***

Mass changing bugs from 1.5-wanted -> 1.6-wanted.
Whiteboard: [1.5-wanted] → [1.6-wanted]
We don't have QQ anymore.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.