Closed Bug 954215 Opened 9 years ago Closed 4 years ago

Possible to select a non-image file as buddy icon

Categories

(Instantbird :: Contacts window, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: benediktp, Unassigned)

References

Details

Attachments

(1 file)

*** Original post on bio 781 at 2011-05-14 13:10:00 UTC ***

The file picker for buddy icons is set to filter for image files only.
Nevertheless it is possible to change the filtering by typing a new pattern into the file input box. This allows to chose non-image files.
No error is shown on the error console though.
Blocks: 953777
*** Original post on bio 781 at 2011-05-23 17:20:20 UTC ***

Discarding non image files seems trivial, probably just adding a null check somewhere. We can still take such a bugfix late in the game.
Whiteboard: [0.3-wanted-final]
Attached patch Patch (WIP)Splinter Review
*** Original post on bio 781 as attmnt 721 at 2011-06-16 23:21:00 UTC ***

This isn't as easy as it seemed. The only reliable way to know if a file is an image is to see if we can decode it as an image. That's what the attached patch does.
However, if we go that far, it's sad to not downscale the image before writing it into the profile folder (so that the next reads become way faster).

Given how non-trivial this patch turns out to be, I'm not sure I still want that for 0.3
*** Original post on bio 781 at 2011-06-17 16:11:59 UTC ***

Per IRC discussion, we are not going to fix this for 0.3 because:
 - the patch is more complicated than we are confortable taking at this point,
 - this is a strange way to interact with the file picker and this is unlikely to actually be in the way of our "real users" (as opposed to "testers").
Whiteboard: [0.3-wanted-final]
Duplicate of this bug: 978461
On the behalf of Florian:
Closing bugs related to the Instantbird UI as WONTFIX, as the development of the standalone chat client Instantbird has stopped. Instantbird users are encouraged to migrate to Thunderbird. The user interface of instant messaging in Thunderbird will feel familiar, as the Thunderbird IM support started as a fork of Instantbird.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.