Automatic unread and read message count update on imap server

RESOLVED DUPLICATE of bug 18266

Status

RESOLVED DUPLICATE of bug 18266
17 years ago
14 years ago

People

(Reporter: moz, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [folderpane])

(Reporter)

Description

17 years ago
Mozilla should update the unread/read message count in the left upper folder
panel  after the first connecting to the imap server. this should be a enable
feature for account because some imap server need long time for this function
like uw-imap.
This should be also started by a Menu entry like
View -> Update message count

Updated

17 years ago
Whiteboard: [folderpane]

Comment 1

17 years ago
Reporter, do you mean that it should update the unread and total counts for all folders 
on the IMAP server and not just that of the INBOX?

Comment 2

17 years ago
*** Bug 95544 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

17 years ago
sure
if your mailbox setup uses filtering like procmail, you currently never sees if 
a new mail is in a subfolder. you have to select all mailboxes to update the 
messagecount for the selected one.

Comment 4

17 years ago
yes!  this is exactly what I need, but this may be a dup of 61428.

I read my work email at home and at work and filter extensively.  And whenever I
switch between home and work, I have to click on every single folder to update
the message count.  Otherwise, as I read my mail I find folders that appear to
be empty  have mail, and folders that look like they only have unread mail,
actually has read mail, and folders that appear to have unread mail, are empty.
 Very annoying and makes it difficult to prioritize what mail to read first.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
I take it back 61428 is dealing with problems when you have filtering set up on
the imap server.

do we have a target milestone for this feature?  I'm sure it's too late for 0.9.4.
Summary: Automatice unread and read message count update on imap server → Automatic unread and read message count update on imap server

Comment 6

17 years ago
I think we currently have problems with newsrc and *.msf files (right?)
scattered around the app. The problem is that we sometimes do not write the
count to these files.  cc bienvenu

Comment 7

17 years ago
this has nothing to do with the newsrc file - the reporter wants us to query the
imap folders on the server for their counts and the solution for 61428 would
solve his problem too (though he only wants it to run once at startup of the
client, I would guess).

 

Comment 8

17 years ago
There has to be a compromise between the current situation of "only check the
inbox until the folder is selected" and the extreme of "check them all and keep
checking them". I do quite extensive filtering, with the volume of email my work
generates thats essential. Unfortunately even though mozilla is set to check my
IMAP account for new mail every 10 minutes I only see new messages appear in my
inbox. Messages delivered elsewhere remain invisible until I actually check the
folder manually by selecting it. On the other hand there are folders that
accumulate a lot of auto-generated informational emails that I dont need the
extra overhead of monitoring - its enough to go and look there when I think
theres a need. 

My preference would be for a per-folder option to say "Include this folder in
checks for new mail" - something akin to the list of "incoming folders" you can
set up in pine :)

Comment 9

17 years ago
First ever bugzilla entry..  do I get a prize?  Anyway..

Switched over from evolution, which provides a knob for this.  I strongly
support the idea of adding a 'check for messages in subfolders' knob.  My mail
filtering is handled server side, and mozilla never bothers to look for new
messages in subfolders.

Comment 10

17 years ago

*** This bug has been marked as a duplicate of 18266 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.