Last Comment Bug 955310 - Enable gio after Linux buildslave distro is updated
: Enable gio after Linux buildslave distro is updated
Status: RESOLVED FIXED
[1.5-nice-to-have]
:
Product: Chat Core
Classification: Components
Component: General (show other bugs)
: trunk
: All Linux
-- normal
: 1.6
Assigned To: Florian Quèze [:florian] [:flo] (PTO until February 27)
:
:
Mentors:
: 955440 (view as bug list)
Depends on:
Blocks: 955431 955440
  Show dependency treegraph
 
Reported: 2013-12-30 06:11 PST by aleth [:aleth]
Modified: 2014-07-25 06:13 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image aleth [:aleth] 2013-12-30 06:11:20 PST
*** Original post on bio 1877 at 2013-02-16 12:01:00 UTC ***

Since moz18, gio is enabled by default: https://bugzilla.mozilla.org/show_bug.cgi?id=713802

It was turned off by hand to enable Linux builds on the current build slave: http://hg.instantbird.org/instantbird/rev/1c6fbe2fff02

This should be reversed when possible since it may cause problems, e.g. "GnomeVFS has been deprecated for a long time, and may not even be shipped by default on modern operating system." I suspect there may be issues on gnome3 in particular (icons, opening links, a11y settings).
Comment 1 User image aleth [:aleth] 2013-12-30 07:26:16 PST
*** Original post on bio 1877 at 2013-06-24 10:38:54 UTC ***

This is the cause of bug 955440 (bio 2004) and (probably) bug 955431 (bio 1995), so hopefully we can fix this before the next release.
Comment 2 User image Florian Quèze [:florian] [:flo] (PTO until February 27) 2013-12-30 09:52:42 PST
*** Original post on bio 1877 at 2013-11-22 07:05:07 UTC ***

This doesn't block the 1.5 release. It's increasingly painful, but it's not a regression, and doesn't justify not shipping the other enhancements to everybody else.
Comment 3 User image Quentin Raynaud 2013-12-30 09:53:27 PST
*** Original post on bio 1877 at 2013-11-22 12:27:02 UTC ***

This was disabled because it was impossible (or at least so painful it didn't make sense) to have the dependencies for gio at the correct version on the Linux slave due to the outdated OS it uses.

If we are going along those lines, better to make a fresh install of a VM to build Linux. It would be safer & quicker. Might be the right choice in fact. The environment on the current slave is becoming more & more difficult to work with.

I believe one of the reason we have not tried to update the Linux slave right now is because we need a spacial version of gcc (I don't remember why) to compile on Linux and we won't have a proper version for another OS / build of CentOS.

Maybe flo can give better feedback as to the wherabout of everything here.
Comment 4 User image aleth [:aleth] 2014-07-25 06:10:42 PDT
Fixed by https://hg.mozilla.org/comm-central/rev/b533b6092f82
Comment 5 User image aleth [:aleth] 2014-07-25 06:11:28 PDT
*** Bug 955440 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.