If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Buddy tooltips have incorrect sizes

RESOLVED FIXED in 1.5

Status

Instantbird
Conversation
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: florian, Assigned: florian)

Tracking

Dependency tree / graph

Details

Attachments

(4 attachments, 2 obsolete attachments)

(Assignee)

Description

4 years ago
*** Original post on bio 2113 at 2013-08-17 01:00:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
(Assignee)

Updated

4 years ago
Blocks: 955433
(Assignee)

Comment 1

4 years ago
Created attachment 8354494 [details] [diff] [review]
Patch

*** Original post on bio 2113 as attmnt 2725 at 2013-08-17 01:00:00 UTC ***

Steps to reproduce:
1. Display a large buddy tooltip.
2. Look at a buddy tooltip with smaller content.

Unexpected result: the tooltip kept the size of the larger tooltip.

This may be Mac only (not sure, but the only 2 people who mentioned it on IRC (nhnt11 and me) are using Macs).

I'm not completely sure, but I suspect this is a regression from the Mozilla 22 update.

The attached hack gets rid of the issue. I would hope we won't need it any more after another (few?) Mozilla updates, but I really don't know...
Attachment #8354494 - Flags: review?(nhnt11)
Comment on attachment 8354494 [details] [diff] [review]
Patch

*** Original change on bio 2113 attmnt 2725 at 2013-08-17 01:31:42 UTC ***

Tested and confirmed working. We decided on IRC to set the minimum width to 200px (which matches the default width of the blist window).
Attachment #8354494 - Flags: review?(nhnt11) → review+
(Assignee)

Comment 3

4 years ago
Created attachment 8354495 [details] [diff] [review]
Patch v2

*** Original post on bio 2113 as attmnt 2726 at 2013-08-17 01:32:00 UTC ***

Per IRC discussion, starting with a default width is better.
Attachment #8354495 - Flags: review?(nhnt11)
(Assignee)

Comment 4

4 years ago
Comment on attachment 8354494 [details] [diff] [review]
Patch

*** Original change on bio 2113 attmnt 2725 at 2013-08-17 01:32:27 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354494 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Assignee: nobody → florian
Comment on attachment 8354495 [details] [diff] [review]
Patch v2

*** Original change on bio 2113 attmnt 2726 at 2013-08-17 01:33:19 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354495 - Flags: review?(nhnt11) → review+
(Assignee)

Comment 6

4 years ago
*** Original post on bio 2113 at 2013-08-17 01:35:32 UTC ***

http://hg.instantbird.org/instantbird/rev/67c3b9175366
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.5

Comment 7

4 years ago
*** Original post on bio 2113 by iLobster <ib.toster AT gmail.com> at 2013-08-18 08:50:00 UTC ***

Windows nightly version 1.5a1pre (20130818041909)
Windows 7 Professional 64-bit
Have problems with incorrect size of buddy tooltips in contact list.
After start of Instantbird can see only first chosen buddy tooltip in correct size (but only first one and only once). Other buddy tooltips are cut. Except one.

https://dl.dropboxusercontent.com/u/15684099/cuted.png
On screenshot 1 I "mouse-over" third buddy in list right after start of Instantbird - it displays correct.
On screenshot 2 it same buddy but now it displays incorrect.
On screenshot 3 it's first in list buddy, "mouse-overed" after steps 1 and 2 - this one displays correct always.
(Assignee)

Comment 8

4 years ago
*** Original post on bio 2113 at 2013-08-18 09:02:31 UTC ***

Reopening per comment 4. If we don't understand what's going on, I think the easiest solution is to add an ifdef XP_MACOSX around the code we added here.

Before doing this, I would like to know if the original bug here existed on Linux, and if the regression exists on Linux.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

4 years ago
*** Original post on bio 2113 at 2013-08-18 13:34:06 UTC ***

(In reply to comment #5)
> Before doing this, I would like to know if the original bug here existed on
> Linux, and if the regression exists on Linux.

I never noticed the original bug on Linux, and the change seems to have added flicker rather than the problems on the Windows screenshots, but I may be mistaken on both counts as I never checked specifically.
(Assignee)

Comment 10

4 years ago
Created attachment 8354515 [details] [diff] [review]
Add ifdef XP_MACOSX

*** Original post on bio 2113 as attmnt 2746 at 2013-08-21 22:48:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Comment on attachment 8354515 [details] [diff] [review]
Add ifdef XP_MACOSX

*** Original change on bio 2113 attmnt 2746 at 2013-08-21 22:50:03 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354515 - Flags: review+
(Assignee)

Comment 12

4 years ago
*** Original post on bio 2113 at 2013-08-21 23:02:17 UTC ***

Comment on attachment 8354515 [details] [diff] [review] (bio-attmnt 2746)
Add ifdef XP_MACOSX

http://hg.instantbird.org/instantbird/rev/ea3cbcee9243
(Assignee)

Comment 13

4 years ago
Created attachment 8354820 [details] [diff] [review]
Better workaround

*** Original post on bio 2113 as attmnt 3039 at 2013-11-11 20:56:00 UTC ***

The work-around we landed here goes badly in the way of the patch from bug 955121 (bio 1693), and I think I've found something cleaner.

It would be interesting to know why the problem only affects the contacts window.
Attachment #8354820 - Flags: review?

Comment 14

4 years ago
Comment on attachment 8354820 [details] [diff] [review]
Better workaround

*** Original change on bio 2113 attmnt 3039 at 2013-11-11 20:57:27 UTC ***

r+ on the basis that it doesn't seem crazy and is better than the present workaround.
Attachment #8354820 - Flags: review? → review+
(Assignee)

Comment 15

4 years ago
Created attachment 8354821 [details] [diff] [review]
Better workaround that actually works

*** Original post on bio 2113 as attmnt 3040 at 2013-11-11 21:13:00 UTC ***

(In reply to comment #9)

> It would be interesting to know why the problem only affects the contacts
> window.

So actually it's the patch from bug 955121 (bio 1693) that "fixes" the problem in the chat window. The patch I attached here alone regresses the tooltips in the chat window :-(.

This new patch should "work everywhere".
Attachment #8354821 - Flags: review?(clokep)
(Assignee)

Comment 16

4 years ago
Comment on attachment 8354820 [details] [diff] [review]
Better workaround

*** Original change on bio 2113 attmnt 3039 at 2013-11-11 21:13:10 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354820 - Attachment is obsolete: true
Comment on attachment 8354821 [details] [diff] [review]
Better workaround that actually works

*** Original change on bio 2113 attmnt 3040 at 2013-11-11 21:14:23 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354821 - Flags: review?(clokep) → review+
(Assignee)

Updated

4 years ago
Blocks: 955121
*** Original post on bio 2113 at 2013-11-11 21:53:52 UTC ***

http://hg.instantbird.org/instantbird/rev/74704f87a57d
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Comment 19

4 years ago
*** Original post on bio 2113 at 2013-11-14 17:05:49 UTC ***

It appears this can also happen on Linux, in the conversation window at least. STR unclear.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

4 years ago
Whiteboard: [1.5-blocking]

Comment 20

4 years ago
Created attachment 8354829 [details] [diff] [review]
Patch to apply workaround to all platforms

*** Original post on bio 2113 as attmnt 3048 at 2013-11-14 17:08:00 UTC ***

Removes the OSX ifdef.
Attachment #8354829 - Flags: review?(florian)

Updated

4 years ago
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 21

4 years ago
*** Original post on bio 2113 at 2013-11-22 07:08:02 UTC ***

Has anybody seen this on Windows too?
Whiteboard: [1.5-blocking] → [1.5-blocking][needs review flo]
(Assignee)

Comment 22

4 years ago
*** Original post on bio 2113 at 2013-11-24 22:12:03 UTC ***

(In reply to comment #13)
> It appears this can also happen on Linux, in the conversation window at least.
> STR unclear.

I've just tried to reproduce with a Linux build for a while and couldn't. Do you see this frequently?

The bug we fixed on Mac happened all the time. If the issue you were seeing on Linux happens only rarely and we don't have steps to reproduce, I'm not sure fixing it "randomly" is a good idea.

Comment 23

4 years ago
*** Original post on bio 2113 at 2013-11-25 16:51:35 UTC ***

(In reply to comment #16)
> I've just tried to reproduce with a Linux build for a while and couldn't. Do
> you see this frequently?

On Linux, I only see it rarely and have no STR. But once it happens, it stays that way. I thought we might use the workaround because it is essentially harmless, but I'm not too concerned if we don't take it for Linux.
(Assignee)

Comment 24

4 years ago
*** Original post on bio 2113 at 2013-12-01 18:01:24 UTC ***

(In reply to comment #17)
> (In reply to comment #16)
> > I've just tried to reproduce with a Linux build for a while and couldn't. Do
> > you see this frequently?
> 
> On Linux, I only see it rarely and have no STR. But once it happens, it stays
> that way. I thought we might use the workaround because it is essentially
> harmless, but I'm not too concerned if we don't take it for Linux.

Given this, I think it's not an 1.5 blocker. And we should possibly track the linux issue in another bug (as the target milestone would be different).
Whiteboard: [1.5-blocking][needs review flo]
(Assignee)

Comment 25

4 years ago
Comment on attachment 8354829 [details] [diff] [review]
Patch to apply workaround to all platforms

*** Original change on bio 2113 attmnt 3048 at 2013-12-01 18:01:39 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354829 - Flags: review?(florian)

Comment 26

4 years ago
*** Original post on bio 2113 at 2013-12-12 14:34:29 UTC ***

(In reply to comment #18)
> > On Linux, I only see it rarely and have no STR. But once it happens, it stays
> > that way. I thought we might use the workaround because it is essentially
> > harmless, but I'm not too concerned if we don't take it for Linux.
> 
> Given this, I think it's not an 1.5 blocker. And we should possibly track the
> linux issue in another bug (as the target milestone would be different).

I think I've changed my mind on this. I see it frequently enough for it to be annoying (extra large tooltips with just the time in them especially).

Comment 27

4 years ago
Comment on attachment 8354829 [details] [diff] [review]
Patch to apply workaround to all platforms

*** Original change on bio 2113 attmnt 3048 at 2013-12-13 12:03:47 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354829 - Flags: review?(florian)
(Assignee)

Comment 28

4 years ago
Comment on attachment 8354829 [details] [diff] [review]
Patch to apply workaround to all platforms

*** Original change on bio 2113 attmnt 3048 at 2013-12-13 12:07:01 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354829 - Flags: review?(florian) → review+

Updated

4 years ago
Whiteboard: [checkin-needed]
*** Original post on bio 2113 at 2013-12-13 21:08:00 UTC ***

Hopefully this is fixed for good.

http://hg.instantbird.org/instantbird/rev/cb330fcc9f73
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Whiteboard: [checkin-needed]
Depends on: 955743
You need to log in before you can comment on or make changes to this bug.