(a11y) selecting accounts in the account manager with arrow keys is hard do to autofocus on connection button

RESOLVED DUPLICATE of bug 955413

Status

Instantbird
Account manager
RESOLVED DUPLICATE of bug 955413
5 years ago
2 years ago

People

(Reporter: Instantbot, Unassigned)

Tracking

x86
Windows 7

Details

(Reporter)

Description

5 years ago
*** Original post on bio 2277 by Hadi Remonion <hadirezaei AT gmx.com> at 2013-12-10 17:49:00 UTC ***

In the account manager window, once an account is selected from the list, the disconnect button will automaticly get focused. This will make ScreenReader users to navigate back to the list each time they go downward through it with the arrow keys, slowing them down untill they find the desired account selected.
The tab/shift+tab order of account manager window is: (the account dropdown list, sign-up at start up checkbox,  disconnect button, delete button, properties, new account, close)
When the account list is focused, pressing the down arrow will select the next account and drop your focus on to the disconnect button. So the process that a ScreenReader user should do is pressing down arrow, shift+tab two times, do this combination untill they select their desired account.

The solution that currently brought up is to have the space key connect/disconnect an account once the account is focused, and selected. instead of jumping the focus onto the connect/disconnect button itself.
Please comment if you think you have a better suggestion for fixing this bug.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 955413
You need to log in before you can comment on or make changes to this bug.