Closed Bug 955413 Opened 6 years ago Closed 4 years ago

[a11y] When arrowing up or down in the accounts list, JAWS doesn't notice the change

Categories

(Instantbird :: Account manager, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Instantbird 48

People

(Reporter: bugzilla, Assigned: aleth)

References

Details

(Keywords: access)

Attachments

(1 file, 1 obsolete file)

*** Original post on bio 1976 by gringochapin <cannona AT gmail.com> at 2013-05-25 14:00:00 UTC ***

Steps to reproduce:
1. Open the accounts window.
2. If only one account is listed, add another so there is at least two.
3. tab until the accounts list is reached.
4. Press the up or down arrow key to move to the next or previous account in the list.
5. Notice that focus changes to the connect or disconnect button.
6. While pressing the down or up arrow key at this point will change the account that currently has focus, screen reader users are not told which account is selected, because as far as the screen reader is concerned, the connect/disconnect button is what has focus, so that is read instead. In order to get this information, a screen reader user must tab back to the account list.

I believe the best solution would be not to change focus to the connect/disconnect button, though if this change were undesirable, it may also be possible to send a message to the screen reader, instructing it to speak the newly focused account name.
Summary: When arrowing up or down in the accounts list, the list loses focus, making it inconvenient for screen reader users. → [a11y] When arrowing up or down in the accounts list, JAWS doesn't notice the change
*** Original post on bio 1976 at 2013-05-25 14:07:21 UTC ***

Also happens in NVDA.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Original post on bio 1976 by gringochapin <cannona AT gmail.com> at 2013-05-25 14:09:08 UTC ***

Confirmed to occur in NVDA 2013.1 and Jaws 13 and 14.
Keywords: access
Duplicate of this bug: 955728
It would be great if someone with a screenreader could test this patch and see if it helps.
Assignee: nobody → aleth
Status: NEW → ASSIGNED
This one actually works (checked with VoiceOver). Note: I'm not sure there's currently a way to get at the connection state and/or error message of the account at all, but nobody seems to have complained about that.
Attachment #8729884 - Flags: review?(florian)
Attachment #8729224 - Attachment is obsolete: true
Severity: minor → normal
OS: Windows XP → All
Duplicate of this bug: 1240954
Comment on attachment 8729884 [details] [diff] [review]
Add the account name to the connect/disconnect button aria label

Review of attachment 8729884 [details] [diff] [review]:
-----------------------------------------------------------------

::: im/content/account.xml
@@ +327,5 @@
>          <![CDATA[
>            let focusTarget = this.activeButton;
> +          let accountName = this.getAttribute("name");
> +          focusTarget.setAttribute("aria-label",
> +                                   focusTarget.label + " " + accountName);

I'm not sure <localized word for "(dis)connect"><space><accountName> will make sense in all languages, but I assume it'll still be better than having no idea of what account is selected.
Attachment #8729884 - Flags: review?(florian) → review+
Depends on: 1256432
https://hg.mozilla.org/comm-central/rev/79efdb39b663b9dbc575e0f9ac6626ee84f65a56
Bug 955413 - Add the account name to the connect/disconnect button aria label. r=florian
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Instantbird 48
You need to log in before you can comment on or make changes to this bug.