Normalize locale codes appropriately for each subsystem

RESOLVED FIXED in Firefox 28

Status

()

Firefox for Android
General
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: rnewman, Assigned: rnewman)

Tracking

(Blocks: 1 bug)

28 Branch
Firefox 29
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Java uses foo_BAR as its locale codes, and that's what we submit via FHR, because we're pulling them from the Android environment.

Gecko requires foo-BAR.

The current implementation goes via a Java Locale object, and thus these get mixed, to unfortunate effect. We only clean up in one direction.

Cleaning this up is a prerequisite for Bug 945122, and also to having UI for this feature.
(Assignee)

Comment 1

4 years ago
Created attachment 8354970 [details] [diff] [review]
Normalize locale codes appropriately for each subsystem.

Verified behavior with es-ES. Not sure where the regression crept in.

This also makes Indonesian work, regardless of which code we send in from the selector ("id" or "in").

Tested by adding "id" to maemo-locales and clobbering.

The Indonesian locale doesn't seem to be complete, but it's complete enough for this:

http://www.youtube.com/watch?v=4nFPz418INY
Attachment #8354970 - Flags: review?(mark.finkle)
(Assignee)

Updated

4 years ago
Attachment #8354970 - Flags: feedback?(jbeatty)
Attachment #8354970 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 2

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/c055952d2078

needinfo on me for uplift if Nightly remains cheerful.
Flags: needinfo?(rnewman)
Target Milestone: --- → Firefox 29
https://hg.mozilla.org/mozilla-central/rev/c055952d2078
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8354970 [details] [diff] [review]
Normalize locale codes appropriately for each subsystem.

I can't seem to verify this on my tablet. Looking in mozilla-central, I don't see Indonesian added to maemo-locales. If that was backed out before I could get to it, that's fine, but it seems like rnewman was able to verify the fix regardless.
Flags: needinfo?(rnewman)
(Assignee)

Comment 5

4 years ago
(In reply to Jeff Beatty [:gueroJeff] from comment #4)

> I can't seem to verify this on my tablet. Looking in mozilla-central, I
> don't see Indonesian added to maemo-locales. If that was backed out before I
> could get to it, that's fine, but it seems like rnewman was able to verify
> the fix regardless.

It never landed -- I made local changes to test. (I figure there's a lot more needs to be done before Indonesian is turned on, and it's not my call to make!)
(Assignee)

Comment 6

4 years ago
Comment on attachment 8354970 [details] [diff] [review]
Normalize locale codes appropriately for each subsystem.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Getting things ready for Indonesian.

User impact if declined: 
  No shipping Indonesian in 28 (and users of the locale-switcher add-on will have breakage for foo-BAR locales).

Testing completed (on m-c, etc.): 
  Tested by hand and no regressions in m-c.

Risk to taking this patch (and alternatives if risky): 
  Should be none. This is only mutating the recently-landed locale switching code.

String or IDL/UUID changes made by this patch:
  None.
Attachment #8354970 - Flags: feedback?(jbeatty) → approval-mozilla-aurora?
(In reply to Richard Newman [:rnewman] from comment #5)
> (In reply to Jeff Beatty [:gueroJeff] from comment #4)
> 
> > I can't seem to verify this on my tablet. Looking in mozilla-central, I
> > don't see Indonesian added to maemo-locales. If that was backed out before I
> > could get to it, that's fine, but it seems like rnewman was able to verify
> > the fix regardless.
> 
> It never landed -- I made local changes to test. (I figure there's a lot
> more needs to be done before Indonesian is turned on, and it's not my call
> to make!)

Good to know :-) Thanks for all of your input and work!
Blocks: 960060
Attachment #8354970 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 8

4 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/3f0b92067746
status-firefox28: affected → fixed
You need to log in before you can comment on or make changes to this bug.