Status

SeaMonkey
UI Design
RESOLVED DUPLICATE of bug 156916
4 years ago
4 years ago

People

(Reporter: currter, Unassigned)

Tracking

SeaMonkey 2.26 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

	hello, I was wondering if there was an easier way to create a new tab without right clicking in open area just top of browsing area? Some other browser use a + or something and I do not see that with Seamonkey...


Actual results:

	hello, I was wondering if there was an easier way to create a new tab without right clicking in open area just top of browsing area? Some other browser use a + or something and I do not see that with Seamonkey...


Expected results:

	hello, I was wondering if there was an easier way to create a new tab without right clicking in open area just top of browsing area? Some other browsers like Firefox or Safari use a + or something and I do not see that with Seamonkey...

Comment 1

4 years ago
Ctrl+T.

Assuming you have at least one tab open, there is a New Tab button as the left-most icon on the tab bar.

If you want to always show the tab bar:
Edit | Preferences | Tabbed Browsing -> (uncheck) Hide the tab bar when only one tab is open

If you want the tab button to be right-most:
http://forums.mozillazine.org/viewtopic.php?f=3&t=2785157
I notice that as time goes by, I use Ctrl+T more and more in comparison to clicking the New Tab icon at the leftmost end of the tab bar.

In particular, when pasting a URL from SeaMonkey into Firefox or vice-versa, Ctrl+T followed by Ctrl+V is very practical.

Happy new year.
(Reporter)

Comment 3

4 years ago
I am aware that one can use the right click once one tab is established.
I want to just press a + button like Firefox (a sister Mozilla browser), Chrome, 
and even Safari all have to open a new tab.  It would be nice to have something
similar in SeaMonkey... if not, then I will stop using it and stick with Firefox,
simple!
(Reporter)

Comment 4

4 years ago
(In reply to currter from comment #3)
> I am aware that one can use the right click once one tab is established.
> I want to just press a + button like Firefox (a sister Mozilla browser),
> Chrome, 
> and even Safari all have to open a new tab.  It would be nice to have
> something
> similar in SeaMonkey... if not, then I will stop using it and stick with
> Firefox,
> simple!

I just don't have time to use software, browsers that can make life more
complicated when I can use other browsers, those mentioned and even Opera
has this similar + feature.
Both Firefox and SeaMonkey already have Ctrl+T. If every user wants to change the hotkey settings, where are we going? INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Component: General → UI Design
Resolution: --- → INVALID
(Reporter)

Comment 6

4 years ago
Well on the Mac, CTRL-T does not seem to work for me. And if it did,
one has to use his/her fingers / keyboard to do that, when I can use
Firefox, Chrome, Safari, Opera and just use the mouse and simply click
on a +  to get a new tab. Is that too much to ask for in SeaMonkey if it
is not available and I am just not seeing it?

It is fine, if SeaMonkey does not offer the + to create a new tab and one
has to right click in the open area to do that, okay. I just won't
use SeaMonkey for that purpose and know to use the other browsers.
That is why there is competition, one has alternatives.

Even a sister browser, Flock, no longer supported/developed, would have
2 tabs that came up upon loading. I still at times use that browser and find
it better in this aspect than SeaMonkey. And just now, I noticed it even has the
+ to create a new tab.

SeaMonkey is just one of those things that just doesn't belong (Sesame Street skit).

Take care.
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(anyoneforagameoftabletennis)
Resolution: INVALID → ---
(Reporter)

Comment 7

4 years ago
Conclusion:

Firefox, Flock (defunct) both sister browsers in the Mozilla family,
Safari, Opera and Chrome all have the + to create a new tab to 
type in another URL.

So far SeaMonkey does not seem to have this simple + feature. 
and that is fine. I will use it less or just think of losing a customer
and I won't tell my clients who want that + feature to use SeaMonkey.
Simple!

Thank you.


Well on the Mac, CTRL-T does not seem to work for me. And if it did,
one has to use his/her fingers / keyboard to do that, when I can use
Firefox, Chrome, Safari, Opera and just use the mouse and simply click
on a +  to get a new tab. Is that too much to ask for in SeaMonkey if it
is not available and I am just not seeing it?

It is fine, if SeaMonkey does not offer the + to create a new tab and one
has to right click in the open area to do that, okay. I just won't
use SeaMonkey for that purpose and know to use the other browsers.
That is why there is competition, one has alternatives.

Even a sister browser, Flock, no longer supported/developed, would have
2 tabs that came up upon loading. I still at times use that browser and find
it better in this aspect than SeaMonkey. And just now, I noticed it even has the
+ to create a new tab.

SeaMonkey is just one of those things that just doesn't belong (Sesame Street skit).

Take care.
(Reporter)

Comment 8

4 years ago
(In reply to Tony Mechelynck [:tonymec] from comment #5)
> Both Firefox and SeaMonkey already have Ctrl+T. If every user wants to
> change the hotkey settings, where are we going? INVALID.

I tested it, on the Mac COMMAND T seems to work
in creating a new tab.

I am not sure what the verdict is in Windows as now I am not on that side
of my Macbook or iMac.

Take care

CMD-T creates a new tab in SeaMonkey under Mac as far as I can tell.
Not everyone uses Windows.
(Reporter)

Comment 9

4 years ago
(In reply to therube from comment #1)
> Ctrl+T.
> 
> Assuming you have at least one tab open, there is a New Tab button as the
> left-most icon on the tab bar.
> 
> If you want to always show the tab bar:
> Edit | Preferences | Tabbed Browsing -> (uncheck) Hide the tab bar when only
> one tab is open
> 
> If you want the tab button to be right-most:
> http://forums.mozillazine.org/viewtopic.php?f=3&t=2785157
On my Mac
CMD-T seemed to work or
rather the funny curly X symbol -T

Maybe it is the same on Windows 

Well that seems better than right click and New Tab in the open spot
but a + click would be very simple I think
(remember Firefox, Flock, Safari, Opera, Chrome and even Internet Explorer
all seem to have a + or similar to create a new Tab) 
SeaMonkey does not  (so I will not mention SeaMonkey again as a browser
choice to some clients who want things simple +).
(In reply to therube from comment #1)
> Ctrl+T.
> 
> Assuming you have at least one tab open, there is a New Tab button as the
> left-most icon on the tab bar.
> 
> If you want to always show the tab bar:
> Edit | Preferences | Tabbed Browsing -> (uncheck) Hide the tab bar when only
> one tab is open
> 
> If you want the tab button to be right-most:
> http://forums.mozillazine.org/viewtopic.php?f=3&t=2785157

    T

    (In reply to Tony Mechelynck [:tonymec] from comment #5)
    > Both Firefox and SeaMonkey already have Ctrl+T. If every user wants to
    > change the hotkey settings, where are we going? INVALID.

    I tested it, on the Mac COMMAND T seems to work
    in creating a new tab.

    I am not sure what the verdict is in Windows as now I am not on that side
    of my Macbook or iMac.

    Take care

    CMD-T creates a new tab in SeaMonkey under Mac as far as I can tell.
    Not everyone uses Windows.

    	

Your comment was:

    (In reply to therube from comment #1)
    > Ctrl+T.
    > 
    > Assuming you have at least one tab open, there is a New Tab button as the
    > left-most icon on the tab bar.
    > 
    > If you want to always show the tab bar:
    > Edit | Preferences | Tabbed Browsing -> (uncheck) Hide the tab bar when only
    > one tab is open
    > 
    > If you want the tab button to be right-most:
    > http://forums.mozillazine.org/viewtopic.php?f=3&t=2785157
    On my Mac
    CMD-T seemed to work or
    rather the funny curly X symbol -T

    Maybe it is the same on Windows 

    Well that seems better than right click and New Tab in the open spot
    but a + click would be very simple I think
    (remember Firefox, Flock, Safari, Opera, Chrome and even Internet Explorer
    all seem to have a + or similar to create a new Tab) 
    SeaMonkey does not  (so I will not mention SeaMonkey again as a browser
    choice to some clients who want things simple +).
Yes, the Accelerator key is Ctrl on Windows and Linux but Cmd on the Mac; forgot about that, but now you mention it, I remember.

So (with Accel defined as above), Accel+T opens a new tab on all three platforms. I don't think there is much chance of getting an _additional_ hotkey (especially considering the fact that _all_ SeaMonkey developers are volunteers, doing it in their spare time) but I may be wrong. Neil has the last word on that, or if he doesn't, he knows who does.

In any case, currter (and in the light of all comments above), I think it would do you good to read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html , especially §§ 1.1, 1.2 and 1.3.
Flags: needinfo?(neil)
(Reporter)

Comment 11

4 years ago
that is okay, I understand limitations.

Just a client asked me about it and all I knew was the
right click but after a tab was already established.
I had recommended this browser as one the client could
use and the client actually listened? but had this
question ( a curve ball then I have to do research here?).

Since the + was expected, I just redirected the client
or reminded of Firefox as an alternative.

I can close this... I just submitted this question quickly
and this was probably the wrong forum/channel to do so.
Maybe someone in development may consider adding the + or
maybe not.

Other browsers do or did not seem to have this + either namely
Camino and maybe Navigator (another Mozilla sister browser)
and both of those are defunct. Maybe SeaMonkey could go the
same direction?

Well take care.
(In reply to currter)
> 	hello, I was wondering if there was an easier way to create a new tab
> without right clicking in open area just top of browsing area? Some other
> browser use a + or something and I do not see that with Seamonkey...

Open Help. type the word tabbed into the search box and from the search results select What is Tabbed Browsing. There you will find a picture of the controls SeaMonkey uses to add and close tabs. You may also want to change your tabbed browsing preferences, e.g. to show the tab bar when only one tab is open.
(In reply to Tony Mechelynck from comment #10)
> I don't think there is much chance of getting an _additional_ hotkey
There isn't, but I don't think that's what he was asking for.
Flags: needinfo?(neil)
(Reporter)

Comment 14

4 years ago
(In reply to neil@parkwaycc.co.uk from comment #12)
> (In reply to currter)
> > 	hello, I was wondering if there was an easier way to create a new tab
> > without right clicking in open area just top of browsing area? Some other
> > browser use a + or something and I do not see that with Seamonkey...
> 
> Open Help. type the word tabbed into the search box and from the search
> results select What is Tabbed Browsing. There you will find a picture of the
> controls SeaMonkey uses to add and close tabs. You may also want to change
> your tabbed browsing preferences, e.g. to show the tab bar when only one tab
> is open.

Oh I had done some of those things before... I now see something on the 
left side it is not a + as was expected it is a * and some webpage or page
symbol.  That seemed to work. I guess I was looking for something on the right
side all this time.

It is the same with the refresh button in some browsers, they are not in
the same expect location based on the browser and have to always locate it
(like a sequential search at times).
There is no consistency between browsers, such is life.

Well thanks. I can forward this information to the client now if the
client wants to continue to use SeaMonkey.

Cheers.
(Reporter)

Comment 15

4 years ago
(In reply to neil@parkwaycc.co.uk from comment #13)
> (In reply to Tony Mechelynck from comment #10)
> > I don't think there is much chance of getting an _additional_ hotkey
> There isn't, but I don't think that's what he was asking for.

But after all that, it seems one still has to initiate an additional tab to see
that Open an New Tab on the left hand side
whereas other browser have an intrinsic + (maybe universally accepted)
button to open a new tab whether additional tabs have been opened or not.
Maybe SeaMonkey has this but may not be intuitive or consistent with other
active browsers out there? (Safari, Chrome, Firefox, Opera) (defunct Flock)
all seem to have an intrinsic + for the initial browser window.
One of these things doesn't belong here, one of these things is just not the same 
-- sesame street...


Well I guess I can close this.
(Reporter)

Comment 16

4 years ago
(In reply to currter from comment #14)
> (In reply to neil@parkwaycc.co.uk from comment #12)
> > (In reply to currter)
> > > 	hello, I was wondering if there was an easier way to create a new tab
> > > without right clicking in open area just top of browsing area? Some other
> > > browser use a + or something and I do not see that with Seamonkey...
> > 
> > Open Help. type the word tabbed into the search box and from the search
> > results select What is Tabbed Browsing. There you will find a picture of the
> > controls SeaMonkey uses to add and close tabs. You may also want to change
> > your tabbed browsing preferences, e.g. to show the tab bar when only one tab
> > is open.
> 
> Oh I had done some of those things before... I now see something on the 
> left side it is not a + as was expected it is a * and some webpage or page
> symbol.  That seemed to work. I guess I was looking for something on the
> right
> side all this time.
> 
> It is the same with the refresh button in some browsers, they are not in
> the same expect location based on the browser and have to always locate it
> (like a sequential search at times).
> There is no consistency between browsers, such is life.
> 
> Well thanks. I can forward this information to the client now if the
> client wants to continue to use SeaMonkey.
> 
> Cheers.

refresh or reload button
different location based on the browser always have to look for it in
different location... maybe should just choose one browser and not
try to juggle all these others (6 to 8 browsers) -- a headache sometimes.
(In reply to currter from comment #15)
> But after all that, it seems one still has to initiate an additional tab to
> see that Open an New Tab on the left hand side

You can change the preferences so that the tabs are always visible.
(Reporter)

Comment 18

4 years ago
Got it... it was just maybe 2 levels of indirection,
first having to change the Preference setting then
thereafter looking for a + symbol to represent opening a new tab
when it is some *paper symbol (excuse if not expressing it 
accurately).

Again, whereas other browsers just have the + and seemingly not have to
do extra work to get to it. Not all browsers are universally similar
I guess even if within the same family (Firefox , Flock).

Thank you.
(Reporter)

Comment 19

4 years ago
RockMelt also uses + to add a new tab FYI
but I have not seen it in OmniWeb
2 other browsers for Mac.
(Reporter)

Comment 20

4 years ago
(In reply to neil@parkwaycc.co.uk from comment #13)
> (In reply to Tony Mechelynck from comment #10)
> > I don't think there is much chance of getting an _additional_ hotkey
> There isn't, but I don't think that's what he was asking for.

I have always communicated with the British better than Americans.
Or a better understanding ... so now

Do you think this new tab symbol could be placed on the right side
that seems more intuitive for the average user. I mean the new opened
tabs are going to appear on the right side so why is the new tab
operator placed on the left side? It just does not make sense I think
and you are moving the mouse/cursor unnecessarily from right to left
back to right where the opened tab is.

Maybe bad programming or not so thoughtful ... or can that be moved
to the right?
Just some thoughts.

Thank you for understanding me better from the United Kingdom than some  Americans.
I do sometimes try to speak the Queen's English. :)
(Reporter)

Comment 21

4 years ago
Oh my, why should I or anyone have to read a novel
of emails and information just to set this new tab thing
on the right side where it should be unless the new URL tabs
open to the left or this is for Arabic type of viewing
(reading from right to left).

Why not have it default on the right side like all other
sensible browsers aforementioned?

Whatever!
(In reply to currter from comment #20)
> (In reply to neil@parkwaycc.co.uk from comment #13)
[...]
> Thank you for understanding me better from the United Kingdom than some 
> Americans.
> I do sometimes try to speak the Queen's English. :)

In case that "some Americans" sentence was meant for me, I am Belgian, my mother language is French, and the English I learnt in school was supposed to be the Queen's. Schools are very inadequate, however, as a way to learn languages, and the books and magazines that I read in English are published on both sides of the Atlantic, and even sometimes in Australia and NZ.

I think it might perhaps be possible to move the new tab button from the left to the right side of the tab bar by means of user CSS. See http://kb.mozillazine.org/UserChrome.css for details. The DOM Inspector extension (which is bundled with some SeaMonkey builds, or can be had from addons.mozilla.org) is an invaluable tool for getting the right IDs and class names to use in user CSS selectors. I've never been interested in moving the new tab button (I like it where it is) but I've had quite some success with user CSS for other purposes, e.g. displaying "very many tabs" on several rows rather than on one horizontally scrolling row. If you're interested, my userChrome.css file can be seen at http://users.skynet.be/antoine.mechelynck/other/userChrome-seamonkey.css — you will probably not want to use it as-is, but it may serve as an example.
I wonder whether this really is a dupe of bug 156916 now. If not, anyone interested in this bug please explain or close.
(Reporter)

Comment 24

4 years ago
Why am I still getting email on this? I thought this was closed or
something. I just think the new tab button (that is not a + symbol)
should be to the right somewhere as that is where the new window will
open in the browser just like other browsers: Firefox, Chrome, Opera, Safari,
Flock and  Internet Explorer) . SeaMonkey is unique and special in its
own little world.

You have my blessing to close this as I am beginning to feel harassed now
continuing to get these emails.

The client now knows how to create a new tab in Seamonkey or has and can use
alternative browsers.

I am done with this.
Bye
(Reporter)

Comment 25

4 years ago
if this was or is a duplicate of another bug , then does that mean
you are too lazy to fix it as I may have rediscovered it?

Surely, does it make sense to have to move your cursor/mouse
from right to left just to open a new tab clicking on something
that may not look too intuitive (not a +) then move the cursor/mouse
back to the right just to get to that window tab opened?
Of course there is always the right mouse button click in the open
space to the right to open a new tab, but I would rather just click the
left mouse button on a + symbol like the other web browsers... but of
course SeaMonkey has to be different.

Do whatever you want, I am done with this!
The Client is happy and not bugging me on how to open a new tab with this.

Fix it or leave it as you want...
It is out of my hands.
(Reporter)

Comment 26

4 years ago
I don't care for this problem any longer
Now I have to find out how to stop getting these
harassing emails here.

Thank you
One comment would have been enough...

Anyway, closing as duplicate of bug 156916. You should not get any further mails for this bug after this one.

In case anyone else considers reopening, please open a new bug instead and explain what exactly you want differing from what bug 156916 is about.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(anyoneforagameoftabletennis)
Resolution: --- → DUPLICATE
Duplicate of bug: 156916
You need to log in before you can comment on or make changes to this bug.