[Buri] "Add Collection" wallpaper label missing

RESOLVED FIXED in Firefox OS v1.4

Status

Firefox OS
Gaia
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: marcia, Assigned: yurenju)

Tracking

({regression})

unspecified
1.3 C2/1.4 S2(17jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.4+, b2g-v1.4 fixed)

Details

Attachments

(2 attachments)

Created attachment 8355034 [details]
Screenshot of issue

Buri, while running:

Gaia   ad7aefdb734c182ac868e68f15026c85c7c115fc
SourceStamp d3dee5e99c1e
BuildID 20131231040201
Version 29.0a1

STR:
1. Long press home screen to change wallpaper
2. Receive attached screenshot

Must be fairly recent regression since this worked a day or so ago.
Note - also check if this reproduces on 1.3.
Component: Gaia::Wallpaper → Gaia::Homescreen
Works fine using Buri and:

Gaia   01e9da49be2cc4bc134eeefc434740d572ec2246
SourceStamp 61f553e5db49
BuildID 20140102004001
Version 28.0a2

Updated

4 years ago
QA Contact: sparsons

Comment 3

4 years ago
This issue started to occur the Buri 1.4 Build ID: 20131231040201

Gaia   ad7aefdb734c182ac868e68f15026c85c7c115fc
SourceStamp d3dee5e99c1e
BuildID 20131231040201
Version 29.0a1


Last working Buri 1.4 Build ID: 20131230040201

Gaia   f7456a5a405b592457a35a80f0236310cdf7307d
SourceStamp 4b242b19b006
BuildID 20131230040201
Version 29.0a1
Keywords: regressionwindow-wanted
This corresponds with the landing of Bug 950857. Adding the developer to the bug.

Updated

4 years ago
Blocks: 950587

Updated

4 years ago
Blocks: 950857
No longer blocks: 950587
Regressing bug is going to 1.3+, so this should also be 1.3+.
blocking-b2g: 1.4? → 1.3?

Comment 6

4 years ago
I checked the source codes, and found that the string is kept in the file: 
apps/homescreen/locales/homescreen.en-US.properties
The variable name was changed. According to the codes, the expected result is to display "Add Smart Collections".

Comment 7

4 years ago
Indeed, some keys were changed in bug #950857 since AFAIK renaming keys is the only way to have strings re-translated.

It seems that the l10n files are not updated with the new keys:
http://hg.mozilla.org/gaia-l10n/en-US/file/b76e2583386f/apps/homescreen/homescreen.properties

is this an l10n issue?
blocking-b2g: 1.3? → 1.3+

Updated

4 years ago
Whiteboard: [systemsfe]
Tim, you guys have more experience with the screen size issues. Can you take this one?
Flags: needinfo?(timdream)
(In reply to Gregor Wagner [:gwagner] from comment #8)
> Tim, you guys have more experience with the screen size issues. Can you take
> this one?

Oh never mind. Wrong bug.
Flags: needinfo?(timdream)
Sam, can you take a look?
Assignee: nobody → sjochimek
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)

Comment 11

4 years ago
Cant reproduce this bug in master.

It seems its a locale bug:

Locale repo: http://hg.mozilla.org/gaia-l10n/en-US/file/b76e2583386f/apps/homescreen/homescreen.properties#l13

In gaia: https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/locales/homescreen.en-US.properties#L13
Flags: needinfo?(lebedel.delphine)
Not sure this is something for me.
Passing the hot potato to Pike (not sure it's for him either though... ;) )
Flags: needinfo?(lebedel.delphine) → needinfo?(l10n)
I think it's the same of bug 956903, and won't be fixed until we can restart string extraction.

Comment 14

4 years ago
I wonder if this is actually a build setup problem.

We should use foo.en-US.properties for en-US instead of en-US/apps/foo/foo.properties, as the latter isn't guaranteed to be compatible with the code in question.

Yuren, Kaze, any idea when and how that could have changed? I suspect that used to work in the past.
Flags: needinfo?(yurenju.mozilla)
Flags: needinfo?(l10n)
Flags: needinfo?(kaze)
Pike, multilocale.js wasn't landed to v1.3, is it a bug in multilocale.py but it still happend in multilocale.js?
Flags: needinfo?(yurenju.mozilla)

Comment 16

4 years ago
I'm a bit lost in the woods on both branches, but it seems that on 1.3 in multilocale.py, en-US is excluded from the processed locales at https://github.com/mozilla-b2g/gaia/blob/v1.3/build/multilocale.py#L246,

    if "en-US" in locales:
        locales.remove("en-US")

Do we have a similar code piece on master?

(Letting kaze off the hook on this one.)
Flags: needinfo?(kaze)
Yuren, the bug only happens on 1.4. Jason moved the flag to 1.3? because the regressing bug landed in 1.3, but comment 2 makes it quite clear that 1.3 works fine.

Therefore I think this is probably a bug in the multilocale.js landing, but since the en-US translations were synchronized on the 19th December on the gaia-l10n repository, we don't see the issue for earlier patches.

Moving the flag to 1.4? per that reasoning.
blocking-b2g: 1.3+ → 1.4?
Duplicate of this bug: 953300
Duplicate of this bug: 956903
Yuren, I'm assigning this bug to you, but feel free to give it to someone else if necessary (eg George ?).
Assignee: sjochimek → yurenju.mozilla
(In reply to Julien Wajsberg [:julienw] from comment #17)
> Yuren, the bug only happens on 1.4. Jason moved the flag to 1.3? because the
> regressing bug landed in 1.3, but comment 2 makes it quite clear that 1.3
> works fine.
> 
> Therefore I think this is probably a bug in the multilocale.js landing, but
> since the en-US translations were synchronized on the 19th December on the
> gaia-l10n repository, we don't see the issue for earlier patches.
> 
> Moving the flag to 1.4? per that reasoning.

1.3 isn't affected yet because the regressing bug hasn't landed on 1.3, but it will plan on landing on 1.3 eventually after this bug gets fixed. The regressing bug here is a stop ship blocker for 1.3. This is just a required followup for that bug that has to be fixed before we uplift that bug.
blocking-b2g: 1.4? → 1.3+
Found the root cause, I did use foo.en-US.properties for en-US instead of en-US/apps/foo/foo.properties but it doesn't happend if we use GAIA_CONCAT_LOCALES because webapp-optimize.js will concat english properties file in locales basedir into json file in locales-obj.
Whiteboard: [systemsfe]
Jason, which is the regression bug? This bug can't be uplifted to 1.3 unless we uplift 922463.
Flags: needinfo?(jsmith)
Oh never mind, I found it (bug 950857)
Flags: needinfo?(jsmith)
Changed component to Gaia because this is a build system bug.
Component: Gaia::Homescreen → Gaia
Created attachment 8360895 [details] [review]
github PR: https://github.com/mozilla-b2g/gaia/pull/15393

Tim, may you review this pull request? thank you!
Attachment #8360895 - Flags: review?(timdream)
Attachment #8360895 - Flags: review?(timdream) → review+
(In reply to Yuren Ju [:yurenju] from comment #23)
> Jason, which is the regression bug? This bug can't be uplifted to 1.3 unless
> we uplift 922463.

After re-read this bug I think Jason is talk about bug 950857?

Given the information we have right now (this regression is caused by non-1.3 code introduced in bug 922463), I think we could safely uplift bug 950857 without the v1.4 patch here. This actually makes this bug not a v1.3+ bug too.

Does that make sense to you Jason?
Yup, makes sense.
blocking-b2g: 1.3+ → 1.4+

Updated

4 years ago
Blocks: 922463
No longer blocks: 950857
Merged.

https://github.com/mozilla-b2g/gaia/commit/fa0f73dde633791612031750c767856fa540088e
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
verified fixed on Buri using:

Gaia   82878ba16172213cd00ba3e8b377564b290e59c1
SourceStamp 324e2cba1029
BuildID 20140116040206
Version 29.0a1

Updated

4 years ago
Duplicate of this bug: 953300
status-b2g-v1.4: --- → fixed
You need to log in before you can comment on or make changes to this bug.