Lots of new GDK-CRITICAL errors

RESOLVED DUPLICATE of bug 95160

Status

RESOLVED DUPLICATE of bug 95160
17 years ago
7 years ago

People

(Reporter: fleona, Assigned: blizzard)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3+) Gecko/20010815
BuildID:    2001081514

Dont know where this one goes

When i start mozilla i get lots of gdk critical messages:
Here they are:

Gdk-CRITICAL **: file gdkpixmap.c: line 63 (gdk_pixmap_new): assertion `(width
!= 0) && (height != 0)' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkpixmap.c: line 63 (gdk_pixmap_new): assertion `(width
!= 0) && (height != 0)' failed.

Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.

Gdk-CRITICAL **: file gdkpixmap.c: line 822 (gdk_pixmap_unref): assertion
`pixmap != NULL' failed.

Gdk-CRITICAL **: file gdkpixmap.c: line 822 (gdk_pixmap_unref): assertion
`pixmap != NULL' failed.

Gdk-CRITICAL **: file gdkpixmap.c: line 63 (gdk_pixmap_new): assertion `(width !=
0) && (height != 0)' failed.
 
Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.
 
Gdk-CRITICAL **: file gdkpixmap.c: line 63 (gdk_pixmap_new): assertion `(width !=
0) && (height != 0)' failed.
 
Gdk-CRITICAL **: file gdkdraw.c: line 89 (gdk_draw_rectangle): assertion
`drawable != NULL' failed.
 
Gdk-CRITICAL **: file gdkpixmap.c: line 822 (gdk_pixmap_unref): assertion `pixmap
!= NULL' failed.
 
Gdk-CRITICAL **: file gdkpixmap.c: line 822 (gdk_pixmap_unref): assertion `pixmap
!= NULL' failed.

Sometimes this leads to a crash. I still can't say why every 2-3 weeks i start
up my machine and i have to reinstall mozilla because it crashes everytime. May
be related

Reproducible: Sometimes
Steps to Reproduce:
1.Launch  mozilla


Actual Results:  Lots of messages, sometimes crash

Expected Results:  The opposite

Comment 1

17 years ago
been going on for some days now. i see these in mailnews and whenever
dialog-boxes or dropdowns in selection boxes in the GUI are clicked. (sidebar,
preferences and more)
Marking dup.

*** This bug has been marked as a duplicate of 95160 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Component: Embedding: GTK Widget → Embedding: GTK Widget
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.