Closed Bug 955976 Opened 6 years ago Closed 6 years ago

[Flatfish]: Launch *.mp4 file in video app causes crash.

Categories

(Core :: Audio/Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29

People

(Reporter: vliu, Assigned: bjacob)

References

Details

(Whiteboard: [Flatfish only][developer+])

This bug is initiated based on bug 924015 Comment 24.

1. Try to |make reset-gaia| or clean data for video app in data partition.
2. Put *.mp4 file into /sdcard/Movies/
3. Launch video app and it will parse fail for *.mp4 file and then pops up crash message for video app.
I tried to roll back the commit id and found the video got crash by adding the patches in bug 897452. Here to arrange the issue we saw in this bug.

Bug 897452 contains 17 commits for its patch.

commit 9f063375a944b79344b9bc44431c41b64fc1a3c8
                 :
                 :
commit 1f2be47e2ac1a54d25bd7628bc5337f7302a4f56

If I put the HEAD in |commit e569b2628d0e92a6d1340ea73649829f84284cb2|, it won't cause crash. Note that |commit e569b2628d0e92a6d1340ea73649829f84284cb2| is cited before |commit 1f2be47e2ac1a54d25bd7628bc5337f7302a4f56|.

Hi :bjacob, 

I need your help to figure it out for what I met. Can you have comment for it? Thanks. If you don't have device to do test, I can help on it.
Flags: needinfo?(bjacob)
this issue is critical for developer program. we targeted to provide final build on 1/15. which means this bug should be fixed in prior.
please keep me posted and let me know if you need any help from me.
Whiteboard: [Flatfish only][developer+]
Does my answer on bug 924015 comment 26 help? In other words: a fix for a possibly related crash just landed on inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/a06e9d86b669

Does it fix the present crash?

If not, would it be possible to get a call stack of the present crash?
Flags: needinfo?(bjacob)
I tried to add the patch you pointed out in the latest sync and it turns out that no crash happens any more. But when I played *.mp4 file, Only audio was playing and got stuck on Video. Because I am not sure the video stuck issue is caused by your patch modification or others, I tried to roll back to |commit 9f063375a944b79344b9bc44431c41b64fc1a3c8|. After that, a build break happens.

../../dist/include/mozilla/RefPtr.h: In static member function 'static T* mozilla::RefPtr<T>::ref(T*) [with T = mozilla::layers::TextureChild]':
../../dist/include/mozilla/RefPtr.h:148:30:   instantiated from 'mozilla::RefPtr<T>::RefPtr(T*) [with T = mozilla::layers::TextureChild]'
../../../gecko/gfx/layers/client/TextureClient.cpp:268:34:   instantiated from here
../../dist/include/mozilla/RefPtr.h:197:9: error: 'class mozilla::layers::TextureChild' has no member named 'AddRef'

Do you have any idea with that? Thanks!!
Flags: needinfo?(bjacob)
That's because the changeset that I mentioned in comment 3 applies on top of an earlier changeset, already landed on mozilla-central: the earlier patch on bug 949347:

https://hg.mozilla.org/mozilla-central/rev/0cc9c500afd9

If you apply first 0cc9c500afd9 and then a06e9d86b669, it should work. Both are on mozilla-central now, anyways.
Flags: needinfo?(bjacob)
Here to have a conclusion for this issue. After the patch of bug 949347 (thanks for :bjacob's great help), it didn't have cash any more. But after that, the video got stuck even the audio run smoothly on its way. Finally, the root cause of this stuck was relative to bug 956193. Disabling hw composer from Settings app can solving the stuck. Based on the above conclusion, I will close this bug. Welcome to reopen it if anyone still has concern.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Assignee: nobody → bjacob
Depends on: 949347
Target Milestone: --- → mozilla29
You need to log in before you can comment on or make changes to this bug.