Closed Bug 956334 Opened 8 years ago Closed 8 years ago

Create in-app products from Devhub

Categories

(Marketplace Graveyard :: Developer Pages, enhancement, P2)

x86
macOS
enhancement

Tracking

(Not tracked)

RESOLVED FIXED
2014-04-08

People

(Reporter: kumar, Assigned: mstriemer)

References

Details

(Keywords: uiwanted, Whiteboard: [feature][qa-])

When you submit an app to Devhub with in-app payments you get a page that shows your Application Key/Secret. See: https://developer.mozilla.org/en-US/Marketplace/Monetization/In-app_payments

This Devhub page should also let the developer create products. A product needs these fields:

- Name
- Price

For bonus points, add these fields (or make a new bug to add them)

- Description
- Localized descriptions
- Icons in various sizes

This will allow JWTs to be created for server-less payments
Blocks: 944480
Depends on: 956333
by Price I meant Price Point
Version: 1.4 → 1.5
Priority: -- → P5
Priority: P5 → P2
Duplicate of this bug: 944490
Whiteboard: [ui-wanted]
Keywords: uiwanted
Whiteboard: [ui-wanted]
Assignee: nobody → asantos
You can find the in-app products creation/editing page here:
http://people.mozilla.org/~bpitoyo/marketplace/payment-account/

Guided walkthrough:
* Mouseover the Action menu on Path app
* Select “In-app products”
* Click “+ Add a new in-app product” three times
* Hover over any product name to rename it

Having not known that this bug exists, I didn’t take Kumar’s bonus points into consideration. But my question around that is: if in-app payment is assigned inside the app — and if DevHub’s only role is to associate the right in-app product with the right URL and price point, so payment can be processed — then why do we need a separate icon and description fields?

My guess: all of the app’s in-app product is listed in the consumer-facing page. For this list to be helpful, it needs to be visualized and localized properly.

If that’s the case, I’m happy to expand the design to include them. I think the prototype hits the essentials for now.
Assignee: asantos → bram
Additionally, you can find the design specification here, on page 15 and 21:
http://people.mozilla.org/~bpitoyo/marketplace/payment-account.pdf
Assignee: bram → mstriemer
Status: NEW → ASSIGNED
Note: its important to put this behind a waffle flag so that we can turn it on when its ready.
Severity: normal → enhancement
Whiteboard: [feature]
https://github.com/mozilla/zamboni/commit/c2a9c2372241439bc26cbf8665b546ec267a2357
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-04-08
Marking as [qa-] until we integrate some more, it's behind a waffle so there should be no change.
Whiteboard: [feature] → [feature][qa-]
You need to log in before you can comment on or make changes to this bug.