[B2G] CutTheRope, does not display correctly during gameplay.

RESOLVED FIXED in Firefox 28, Firefox OS v1.3

Status

()

Core
Canvas: 2D
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: RolandK, Assigned: pchang)

Tracking

({regression})

unspecified
mozilla29
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:1.3+, firefox27 wontfix, firefox28 fixed, firefox29 fixed, b2g-v1.3 fixed)

Details

(Whiteboard: dogfood1.3)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
During gameplay the stars in the upper left corner of the game become truncated. Also, all text during gameplay, (not the menus or buttons used to navigate the app), appears improperly and cannot be read.

Setup Steps:
Enable Cellular Data or connect to a wireless network.

Repro Steps:
1) Update Buri to v1.3 BuildID: 20140103004001
2) Access the marketplace app.
3) Download the app, CutTheRope.
4) Open the app, CutTheRope and observe the end of level screen.

Actual:
Star graphics appear truncated and end of level screen appears distorted.

Expected:
Game to be displayed correctly.

Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20140103004001
Gaia: ae7d05689b6b9ac4ec6182217dfdef06be28e886
Gecko: d9226a660d52
Version: 28.0a2
Firmware Version: 20131115

Notes:
For comparison I tested the app on a Samsung Galaxy s3 LTE phone to make sure the game was in fact displaying incorrectly.

Repro frequency: 100%

Link to video: 
http://www.youtube.com/watch?v=OOqlYpG6yBg
(Reporter)

Comment 1

4 years ago
Created attachment 8355688 [details]
Top Left Stars
(Reporter)

Updated

4 years ago
Whiteboard: dogfood1.3
Looks like a layout regression. Can you check if this reproduces on 1.2?
Keywords: qawanted
(Reporter)

Comment 3

4 years ago
(In reply to Jason Smith [:jsmith] from comment #2)
> Looks like a layout regression. Can you check if this reproduces on 1.2?

This issue does reproduce on the latest v1.2 Buri build.

Environmental Variables:
Device: Buri v1.2 Mozilla RIL
BuildID: 20140103004001
Gaia: 2b116456d8a3ed3e9741b370d628f225c58587da
Gecko: 9cbbf14a0f69
Version: 26.0
Firmware Version: 20131115
Keywords: qawanted
QA Contact: rkunkel
What about 1.1?
Keywords: qawanted
(Reporter)

Comment 5

4 years ago
Created attachment 8355695 [details]
CutTheRope_v1.1
(Reporter)

Comment 6

4 years ago
(In reply to Jason Smith [:jsmith] from comment #4)
> What about 1.1?

Unable to test on v1.1. When opening the app the user is brought to the "Index of app..." instead of launching correctly.

This issue has been written up, bug# 949094

Attaching additional attachment.
(Reporter)

Comment 7

4 years ago
Removing qawanted. Also, this issue is not a duplicate of bug# 949094, it is just similar. Different apps are involved in the process.
Keywords: qawanted
(In reply to Roland Kunkel [:RolandK] from comment #7)
> Removing qawanted. Also, this issue is not a duplicate of bug# 949094, it is
> just similar. Different apps are involved in the process.

bug 949094 is a 1.4-specific bug.

This issue can be worked around btw if you hit it - you need to open the index HTML file directly by clicking on it. Can you check if it reproduces on 1.1 after clicking the index HTML page that appears?
Keywords: qawanted
(Reporter)

Comment 9

4 years ago
(In reply to Jason Smith [:jsmith] from comment #8)

> This issue can be worked around btw if you hit it - you need to open the
> index HTML file directly by clicking on it. Can you check if it reproduces
> on 1.1 after clicking the index HTML page that appears?

Ah! I was unaware of this work-around. 

> What about 1.1?

This issue does not reproduce on the latest v1.1 build.

Environmental Variables:
Device: Buri v1.1 Mozilla RIL
BuildID: 20140102041202
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Gecko: bdac595a4e46
Version: 18.0
Firmware Version: 20131115
Keywords: qawanted
This is an obvious blocker, as this is a partner app.
blocking-b2g: --- → 1.3?
Keywords: regression, regressionwindow-wanted

Updated

4 years ago
Component: General → Layout
Product: Firefox OS → Core

Updated

4 years ago
Priority: -- → P2
(Assignee)

Comment 11

4 years ago
I'm able to reproduce this issue on my leo device based on master branch.
But I couldn't reproduce this issue by using firefox.
Assignee: nobody → pchang
(Assignee)

Comment 12

4 years ago
Created attachment 8356491 [details]
2014-01-07-17-08-59.png

Inside cut the rope, it stores 11 elements in one image file for the star animation.
By default, the star came from frame 0(first element). I changed it to frame 10 and I could always see the problem.
(Assignee)

Comment 13

4 years ago
(In reply to peter chang[:pchang] from comment #11)
> I'm able to reproduce this issue on my leo device based on master branch.
> But I couldn't reproduce this issue by using firefox.

Correct: I could reproduce it on mac firefox by changing canvas backend as skia.
Therefore, this should be related to skia, not layout.
(Reporter)

Comment 14

4 years ago
(In reply to Jason Smith [:jsmith] from comment #10)

It appears the issue occured between 9/6 and 9/9. I was unable to find the builds for 9/7 and 9/8. 

- Last Working -

9/6
Environmental Variables:
Device: Buri 1.2 MOZ
BuildID: 20130906040204
Gaia: 94e5f269874b02ac0ea796b64ab995fce9efa4b3
Gecko: ab5f29823236
Version: 26.0a1

- First Broken -

9/9
Environmental Variables:
Device: Buri 1.2 MOZ
BuildID: 20130909114657
Gaia: aa4180e9286d385fa6b62d236f30fb24cd8b93e9
Gecko: 218d4334d29e
Version: 26.0a1
Firmware Version: 20131115
Keywords: regressionwindow-wanted
(In reply to peter chang[:pchang] from comment #13)
> Correct: I could reproduce it on mac firefox by changing canvas backend as
> skia.
> Therefore, this should be related to skia, not layout.

Good find. As further confirmation that this is a Skia-related issue, the regression range from comment 14 includes this change:
> d9e41df7445c	Benoit Jacob — Bug 905227 - Turn on Skia/GL on B2G - r=nical
That changeset is: http://hg.mozilla.org/mozilla-central/rev/d9e41df7445c

Seems likely to have been regressed by that changeset.

(The full regression range is: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ab5f29823236&tochange=218d4334d29e )
Blocks: 905227
Component: Layout → Canvas: 2D
(Assignee)

Updated

4 years ago
Duplicate of this bug: 957407
(Assignee)

Comment 17

4 years ago
This is related to the rounding issue inside the DrawTargetSkia::DrawSurface function because it is using SkIntRect for source region. Change to SkRect could fix the problem.

Updated

4 years ago
Duplicate of this bug: 957264

Updated

4 years ago
blocking-b2g: 1.3? → 1.3+
(Assignee)

Comment 19

4 years ago
Created attachment 8358246 [details] [diff] [review]
Fix rounding issue inside DrawTargetSkia::DrawSurface
(Assignee)

Comment 20

4 years ago
Update the try server link.
https://tbpl.mozilla.org/?tree=Try&rev=30870a891bf2
(Assignee)

Updated

4 years ago
Attachment #8358246 - Flags: review?(gwright)
(Assignee)

Comment 21

4 years ago
Inside cut the rope, it inputs the float numbers as source rect to display the 'star' icons and other 'text' images. It caused the rounding issue inside DrawTargetSkia::DrawSurface because using drawBitmapRect with SkIntRect.

http://mxr.mozilla.org/mozilla-central/source/content/canvas/src/CanvasRenderingContext2D.cpp#3039
I'm curious to know why this broke as the code that's modified in the patch is over a year old, but drawBitmapRectToRect is a new function that was introduced upstream in Skia that does what we want for DrawSurface and removes the requirement for the hack that's currently in there, so I'm okay with r+ing this.

We should investigate this further though.
Attachment #8358246 - Flags: review?(gwright) → review+
(Assignee)

Comment 23

4 years ago
Created attachment 8360227 [details] [diff] [review]
Fix rounding issue inside DrawTargetSkia::DrawSurface v2

Rebase and update reviewer
Attachment #8358246 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Attachment #8360227 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/0d949d0bd3df
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
https://hg.mozilla.org/releases/mozilla-aurora/rev/2abe1f3609bd
status-b2g-v1.3: --- → fixed
status-firefox27: --- → wontfix
status-firefox28: --- → fixed
status-firefox29: --- → fixed
You need to log in before you can comment on or make changes to this bug.