Some websites are loaded zoomed in

RESOLVED WONTFIX

Status

()

Firefox for Android
Toolbar
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: Flaviu Cos, Unassigned)

Tracking

({reproducible})

Trunk
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(firefox26 affected, firefox27 affected, firefox28 affected, firefox29 affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Environment: 
Device: Google Nexus 7 (Android 4.4);
Build: Nightly 29.0a1 (2014-01-06);

Steps to reproduce:
1. Visit any website (e.g: www.imdb.com; www.gsmarena.com; m.yahoo.com; ebay.com);
2. Check if the website is completely zoomed out.

Expected result:
The website is not zoomed in. 

Actual result:
The website is zoomed in.
Created attachment 8356115 [details]
screenshot.png

Each indicated site is displayed fit to form for me.

Please provide steps to reproduce and make sure you do not have any possible add-ons as candidates interfering.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: steps-wanted
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

4 years ago
Created attachment 8356121 [details]
device-2014-01-06-172001.png

Reproduced with Google Nexus 7 (Android 4.4);
Also reproducible with Asus Transformer Tab (Android 4.0.3);
Please check the attached screen shots.
(Reporter)

Comment 3

4 years ago
Created attachment 8356122 [details]
device-2014-01-06-172128.png
(Reporter)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I see this on my Nexus 7 on all-channels. This seems like a long-standing issue with likely another bug open for this.

Nexus 7 (2013, Android 4.4.2)

Kats, do you know of this issue longstanding? Here's a video: http://people.mozilla.org/~atrain/misc/956720.mp4
status-firefox26: --- → affected
status-firefox27: --- → affected
status-firefox28: --- → affected
status-firefox29: --- → affected
Flags: needinfo?(bugmail.mozilla)
* In the video, I need to do a zoom out to reveal the entirety of the page. If you notice in the top right, the 'Help' menu on IMDB is initially partially off-screen but is revealed after the zoom.
I'm not aware of any bug open for this issue. The closest is bug 935615 but that is probably not even the same thing.
Flags: needinfo?(bugmail.mozilla)

Updated

4 years ago
Status: REOPENED → NEW
tracking-fennec: --- → ?
Keywords: steps-wanted → reproducible
Matt - The screenshots (#2 and #3) show the pages are slightly larger than the viewport. Didn't we intend it to work this way?
Flags: needinfo?(mbrubeck)
Yes, if I remember right, in general we initially render "desktop" pages the same way they appear in a 980px-wide desktop Firefox window.  The IMDB page is 1008px wide, so it is horizontally scrollable in both Fennec, just as it is in a 980px desktop Firefox window.

We could (and I think did at some point?) always set the initial scale to the minimum possible value, but this provides a somewhat worse experience in certain cases (e.g. wide, horizontally-scrolling pages, which get extremely zoomed out).  Or we could have some logic to zoom out to the page width but only up to a certain threshold; for very wide pages we could still fall back to the current behavior of zooming out to the viewport width.

I think we've actually gone back and forth on this one or more times, but I couldn't find the relevant bugs except for bug 475997 (which never landed).
Flags: needinfo?(mbrubeck)
Matt's recollection matches mine. Unless we intend to change (again) our behavior, the app is working as designed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
tracking-fennec: ? → ---

Updated

4 years ago
Duplicate of this bug: 958397
You need to log in before you can comment on or make changes to this bug.