Closed Bug 956841 Opened 7 years ago Closed 7 years ago

[B2G][Dialer][Bluetooth] Navigation perf occurs while within a bluetooth call

Categories

(Firefox OS Graveyard :: Bluetooth, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:1.4+, firefox28 wontfix, firefox29 fixed, b2g-v1.3 unaffected, b2g-v1.3T unaffected, b2g-v1.4 verified)

VERIFIED FIXED
1.3 C2/1.4 S2(17jan)
blocking-b2g 1.4+
Tracking Status
firefox28 --- wontfix
firefox29 --- fixed
b2g-v1.3 --- unaffected
b2g-v1.3T --- unaffected
b2g-v1.4 --- verified

People

(Reporter: gbennett, Assigned: tzimmermann)

References

()

Details

(Keywords: perf, regression, Whiteboard: [c=handeye p= s=2014.01.17 u=1.4])

Attachments

(2 files, 1 obsolete file)

Attached file BluetoothPerf_LOG.txt
Description:
While within a Bluetooth call if you press the home button and navigate around the phone the framerate will drop significantly and become unresponsive at times for 3-8 seconds.

Repro Steps:
1) Updated Buri to BuildID: 20140106040201
2) Connect a bluetooth headset device
3) Make a phone call and have the other phone answer
4) Press the home button and attempt to go into the settings app

Actual:
Severe perf occurs and navigating the phone is quite difficult.

Expected:
User is able to navigate anywhere on the phone while in a bluetooth call.

Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140106040201
Gaia: 9a222ac02db176e47299bb37112ae40aeadbeca7
Gecko: 14ac61461f2a
Version: 29.0a1
Firmware Version: v1.2_20131115

Notes: This does not occur on 1.3. There is a crash shown in the video due to the perf a Bluetooth call creates. Let me know if that should be written separately.

Repro frequency: 3/3, 100%
See attached: http://www.youtube.com/watch?v=sUTptGN3Zms, BluetoothPerf_LOG.txt
Link to the crash that occured. It seems this bug causes an older crash.

https://crash-stats.mozilla.com/report/index/e525fa38-54af-4dfe-98bd-37ee72140106
blocking-b2g: --- → 1.4?
I'll take this one. Since this doesn't occur on v1.3, I'm not going to do it this week. Will start to investigate next Monday.
Assignee: nobody → echou
Status: NEW → ASSIGNED
Priority: -- → P2
Whiteboard: [c=handeye p= s= u=]
QA Contact: sparsons
This issue started to occur on the Buri 1.4 Build ID: 20131213040203

Gaia   390b313a254a947d12e3cdbcde19d7d1619ff63c
SourceStamp 8b5875dc7e31
BuildID 20131213040203
Version 29.0a1

Last working Buri 1.4 Build ID: 20131212040203

Gaia   8952898bbc98dd31e25b647203791cf129867ff1
SourceStamp 1ad9af3a2ab8
BuildID 20131212040203
Version 29.0a1
Update: I can reproduce. Still trying to find the root cause.

> Repro Steps:
> 1) Updated Buri to BuildID: 20140106040201
> 2) Connect a bluetooth headset device

Actually this step is not necessary. The issue could be easily reproduced as long as Bluetooth is on.

> 3) Make a phone call and have the other phone answer
> 4) Press the home button and attempt to go into the settings app
This is a regression of bug 932728. Still figuring out the root cause.
Hi Thomas,

After bisect I found out that this bug seems to be caused by bug 932728. Would you mind taking a look?
Flags: needinfo?(tzimmermann)
Blocks: 932738
Blocks: 932728
No longer blocks: 932738
Ok, I'll have a look.
Assignee: echou → tzimmermann
Flags: needinfo?(tzimmermann)
triage: regression 1.4+ to make sure this gets fixed in 1.4
blocking-b2g: 1.4? → 1.4+
I was able to reproduce the issue. It's caused by constantly reporting DBus sockets to be writable by calling OnFileCanWriteWithoutBlocking in the I/O thread. The attached patch fixes the problem for me.
Attachment #8359796 - Flags: review?(kyle)
Comment on attachment 8359796 [details] [diff] [review]
[01] Bug 956841: Respect DBusWatch flags in I/O-thread watchers

Review of attachment 8359796 [details] [diff] [review]:
-----------------------------------------------------------------

::: ipc/dbus/DBusThread.cpp
@@ +124,5 @@
>    MessageLoopForIO* ioLoop = MessageLoopForIO::current();
> +
> +  unsigned int flags = dbus_watch_get_flags(mWatch);
> +
> +  if (flags&DBUS_WATCH_READABLE) {

supernit: Spaces around the & might be more readable, here and below.
Attachment #8359796 - Flags: review?(kyle) → review+
https://hg.mozilla.org/mozilla-central/rev/559465ad3fd8
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [c=handeye p= s= u=] → [c=handeye p= s=2014.01.17 u=1.4]
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
Keywords: verifyme
Unable to reproduce on todays Buri v1.4. Verified fixed.

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ
BuildID: 20140502000201
Gaia: 7b2b82d72cbdd1c7e0f4542cb3390802e65f473e
Gecko: 50be03cea340
Version: 30.0
Firmware Version: v1.2-device.cfg

Also unable to reproduce on todays Open C v1.4
v1.4 Environmental Variables:
Device: Open C v1.4
BuildID: 20140502000201
Gaia: 7b2b82d72cbdd1c7e0f4542cb3390802e65f473e
Gecko: 50be03cea340
Version: 30.0
Firmware Version: P821A10_ENG_20140410
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.