Closed Bug 957034 Opened 6 years ago Closed 5 years ago

PDF Viewer is not displaying hyperlinks correctly.

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: npuck, Assigned: Snuffleupagus)

References

Details

(Whiteboard: [pdfjs-c-rendering] https://github.com/mozilla/pdf.js/pull/4080)

Attachments

(1 file)

Attached file pdf file with blacked out hyperlinks (obsolete) (deleted) —
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

I opened a pdf file in the firefox embedded pdf viewer.  The pdf file was originally created by crystal reports and then downloaded from the pdf viewer and attached here. (notice the double .pdf, but according to a bug report, this should be fixed now)


Actual results:

The hyperlinks ("mailto:") within the pdf are covered by black boxes.  I also tested with http hyperlinks with the same results.


Expected results:

The hyperlinks should have displayed.
Component: Untriaged → PDF Viewer
I can confirm but please do not upload sensitive data as a testcase.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Version: 26 Branch → Trunk
This replaces the original test case in which the problem was confirmed, but removes the sensitive data.
I have uploaded a new test case with all data dummied out.  (I was afraid if I did this in the original, it might get the blame for the problem).  While this is data from a public website, you are right in that it would be better to not have sensitive data included.  Is there a way to delete the original file?
Thanks for your assistance.
Natalie
The original file is currently visible only to our security group; CCing glob to see if more action needs to be taken here.

Gerv
The content of attachment 8356454 [details] has been deleted for the following reason:

attachment contents deleted as per comment 4.
Assignee: nobody → jonas.jenwald
Whiteboard: [pdfjs-c-rendering] https://github.com/mozilla/pdf.js/pull/4080
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: 960051
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
You need to log in before you can comment on or make changes to this bug.