Closed Bug 95704 Opened 19 years ago Closed 16 years ago

[patch]the keyboard stops working when window is minimized and then maximized again

Categories

(Core :: Layout: Form Controls, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: madhur, Assigned: bryner)

References

()

Details

(Keywords: testcase, Whiteboard: [no ETA])

Attachments

(3 files)

specific to Mac OS-10 
build tested on : 2001-08-08-06trunk 

1. Go to the above mentioned url
2. type something in the text boxes
3. minimize the window
4. now maximize the window again.
5. use the arrow keys to go left or right [OR] try typing something else

actual: The keyboard goes dead - stops working

If i click on another some other textbox... the keyboard starts working again. 
Another scenario is , when I hit the back browser button and then the 'forward' 
button -- the keyboard gets activated again.
Yep. The cursor ,which is in the active field, is not functioning when key is
pressed. Checked on Mac OS X 10.0.4 with Aug 22nd build. CC pinkerton, sdagley.
Easy workaround, but could be quite annoying for users. Nominating for branch.
Keywords: nsbranch
This sounds like somebody needs to set focus on the window when it gets 
maximized. Dan M. did all the maximize work, he should look at this bug.
Dan can you take a look at this one?
Assignee: rods → danm
oy. sure. when i get an OS X box. not this milestone.
Whiteboard: OSX+
Is this important to releasing builds for OS X?  If not, pls -.  
Dan - Pls provide us with an ETA for this one.
Whiteboard: OSX+ → OSX+,[ETA?]
see my comment above, dated 2001-09-19 15:28 
Whiteboard: OSX+,[ETA?] → OSX+,[no ETA]
There is an existing workaround (i.e. Click into a field). = PDT-
Whiteboard: OSX+,[no ETA] → OSX+,[no ETA], PDT-
Whiteboard: OSX+,[no ETA], PDT- → OSX-,[no ETA], PDT-
Blocks: 102998
*** Bug 100822 has been marked as a duplicate of this bug. ***
what target milestone is this bug going to be set for? 
It is an annoying bug and user will come across it.
Blocks: 107065
Keywords: nsbranch
Seeing this with Linux/x86 under fvwm2
Please change Platform/OS to All/All
I am also seeing this on Win 2k using build 2001112803.

I am marking this all/all.
OS: MacOS X → All
Hardware: Macintosh → All
Whiteboard: OSX-,[no ETA], PDT- → [no ETA]
Target Milestone: --- → Future
Still not fixed with 2002013010 branch and 2002013012 trunk.
I should note that the described workaround is NOT working for me. The only way
to continue using mozilla is to open a new window with the mouse and close the
old window with the mouse.
See also my comment in bug 107405#c17
nominating as nsbeta1 ...

can we get this one in before M1.0?
Keywords: nsbeta1
nsbeta1+ per ADT triage team
Keywords: nsbeta1nsbeta1+
taking since I think I have a grasp on the issue
Assignee: danm → saari
Keywords: nsbeta1+nsbeta1
Target Milestone: Future → mozilla0.9.9
Keywords: nsbeta1nsbeta1+
Blocks: keydead
Is this patch being reviewed or has it been postponed until after 1.0 ?
saari: Any chance you could add some linux and osx magic to your patch?
another dupl of bug 82534?
Blocks: 180209
No longer blocks: 102998
Keywords: testcase
Attached file Testcase
Reproduced on Mac 12/16 Trunk Build, OSX
Target Milestone: mozilla0.9.9 → ---
->bryner is about to fix the Mac version of this. Works on win32 for me
Assignee: saari → bryner
from #26, did bryner fixed it ? adding self and brian in cc in order to know the
status of this.
Brian did you fixed thi issue ?
Summary: the keyboard stops working when window is minimized and then maximized again → [patch]the keyboard stops working when window is minimized and then maximized again
Note the second patch, attachment 73114 [details] [diff] [review], has already been checked in for bug
82534 (though the nsWebShellWindow part was #ifdef XP_WIN).
Confirming this works now on Windows Mozilla 1.8a2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040603

The Mac part of the fix was not checked in -- so it's probably still broken there.

BTW, don't we mean "restore" and not "maximize" for this bug?
OS: All → MacOS X
WFM in 1.8a6 for OS X.

All but changes in the patch except those made to to the last file have since
been checked into the trunk. So, if it makes more sense to mark this as fixed,
feel free.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.