Download notification date is 2027

VERIFIED FIXED in Firefox 27

Status

()

Firefox for Android
Download Manager
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: TeoVermesan, Assigned: Federico Paolinelli)

Tracking

({regression})

27 Branch
Firefox 27
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox26 unaffected, firefox27+ verified, firefox28 unaffected, firefox29 unaffected, fennec27+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8356561 [details]
Date Download Notification

Tested with:
Build: Firefox for Android 27 Beta 4
Device: LG Nexus 4
OS: Android 4.3

Steps to reproduce:
1. Go to http://goo.gl/SRCLe to download the file
2. Go to android notification bar

Expected result:
- The download notification date should be correct

Actual result:
- The download notification date is 10/12/2027

Please see the attached screenshot
(Reporter)

Updated

5 years ago
Summary: Download notification date is 10/12/2027 → Download notification date is 2027
(Reporter)

Updated

5 years ago
status-firefox27: --- → affected
status-firefox28: --- → unaffected
status-firefox29: --- → unaffected
This is the same as bug 933775, but it was uplifted to mozilla-beta in early December.

Is the date correct on the device? Reproducible on other devices?
(Reporter)

Comment 2

5 years ago
Yes, the date is 07/01/2014.
Reproducible on Samsung Galaxy Tab (Android 4.0.4) and Google Nexus 7 (Android 4.4)
Federico/gcp is there a code disparity on mozilla-beta and other branches for this?
Flags: needinfo?(fedepaol)
The patch looks OK to me in mozilla-aurora and mozilla-beta, though the file itself is fairly different.

This bug has dates in the future. The bug you refer to had dates in the past (really, unix time 0). So it's not exactly the same, though the cause probably ain't too far away.

Updated

5 years ago
tracking-fennec: --- → ?
tracking-firefox27: --- → ?
(Assignee)

Comment 5

5 years ago
I guess the bug is here http://mxr.mozilla.org/mozilla-beta/source/mobile/android/chrome/content/downloads.js#99

The NotificationBuilder expects the when parameter as the number of millisecs since the epoch, whereas aDownload.startTime is the same time expressed in microsecs, so its the number it expects * 1000.

I can provide a patch tomorrow, since I don't currently have a beta checkout and I would like to test the patch before submitting.
Flags: needinfo?(fedepaol)
(Assignee)

Comment 6

5 years ago
Created attachment 8356853 [details] [diff] [review]
bug-957120-fix

This is the patch. I guess the bug affects only beta, since from aurora the when parameter is calculated in a different way.
Attachment #8356853 - Flags: review?(wjohnston)
Attachment #8356853 - Flags: review?(wjohnston) → review+
Frederico, can you request beta approval for your patch?
Flags: needinfo?(fedepaol)
(Assignee)

Comment 8

5 years ago
Sure, I just need to know how to do it :)
Flags: needinfo?(fedepaol)
Click on your patch->details->approval-mozilla-beta?  It will give you a template to fill in.

Updated

5 years ago
tracking-firefox27: ? → +

Updated

5 years ago
Assignee: nobody → fedepaol
(Assignee)

Comment 10

5 years ago
Comment on attachment 8356853 [details] [diff] [review]
bug-957120-fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 933775 
User impact if declined: Wrong download date time in download notification
Testing completed (on m-c, etc.): Tested on checked out beta
Risk to taking this patch (and alternatives if risky): Low, only changed the value to be used as notification time
String or IDL/UUID changes made by this patch: None
Attachment #8356853 - Flags: approval-mozilla-beta?

Updated

5 years ago
Blocks: 933775
status-firefox26: --- → unaffected
Keywords: regression, verifyme

Updated

5 years ago
Attachment #8356853 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/4a876256830e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox27: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
tracking-fennec: ? → 27+

Comment 12

5 years ago
Verified as fixed in  build: 27 beta 6;
Device: Google Nexus 7 (Android 4.4.2);
Status: RESOLVED → VERIFIED
status-firefox27: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.