Closed Bug 933775 Opened 6 years ago Closed 6 years ago

Regression: Timestamp on download notifications is false; date stuck in 1970

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 28
Tracking Status
firefox26 --- unaffected
firefox27 + verified
firefox28 --- verified
fennec 27+ ---

People

(Reporter: aaronmt, Assigned: gcp)

References

Details

(Keywords: regression)

Attachments

(2 files)

Download a file, see notification; see time-stamp from 1970.
Blocks: 921776
Needs a fix. I might be wrong, but when I implemented this the timestamp was not showing up. Looks like setShowWhen was introduced in api level 17, maybe I was just building against 16?
Anyway, do we want to show here the proper time OR to hide the date as it was before I started messing this whole thing up (:-( ) ?
I will investigate into the cause of the wrong time anyway. The when parameter is necessary in order to preserve the order of the notifications.
Attached patch bug-933775-fixSplinter Review
Attachment #826489 - Flags: review?(wjohnston)
Forgot to add the comment. In this version I just fixed the time issue, still I am not sure if we want to show the time into the notifications. In the released build we do not have anything like that.
As per the other comment, should we back bug 909932 until we fixed all these issues?
Duplicate of this bug: 934462
Attachment #826489 - Flags: review?(wjohnston) → review+
tracking-fennec: ? → 27+
Why hasn't this landed?
Attached image 1969.png
Adding checkin-needed. Hopefully this applies cleanly.
Keywords: checkin-needed
Frederico, fix your hg configuration so it adds author information to patches. I checked this in and got set as author because it wasn't set in the patch.

https://hg.mozilla.org/integration/mozilla-inbound/rev/a5f547833e7d1
Damn, thanks for pointing out. It looks like I forgot to readd them after reinstalling the os on my laptop. I am afraid there are some other patches in this state :(
https://hg.mozilla.org/mozilla-central/rev/a5f547833e7d
Assignee: nobody → gpascutto
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Can we get this verified so it can be uplifted?
Status: RESOLVED → VERIFIED
Keywords: verifyme
Comment on attachment 826489 [details] [diff] [review]
bug-933775-fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 909932
User impact if declined: Nonsense download timestamps
Testing completed (on m-c, etc.): On m-c for a few weeks
Risk to taking this patch (and alternatives if risky): Effectively none.
Attachment #826489 - Flags: approval-mozilla-beta?
Attachment #826489 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Depends on: 957120
Verified on Firefox for Android 27 Beta 8
Device:LG Optimus 4X (Android 4.1.2)
You need to log in before you can comment on or make changes to this bug.