bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[paas.allizom.org] Push of new app ignores framework

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: IT-Managed Tools
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mkelly, Assigned: jd)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
While putzing around with bug 956819, I tried to re-create oneanddone with the new 3.0.1 client. The setup didn't seem to finish (it didn't log installation of stuff from PyPI) and starting the app resulted in failure.

Here's the log: http://pastebin.mozilla.org/3959764

The weird part is when it ignores the choices I've made for framework, memory, and instances:

    Warning, ignoring local change of Framework: python (keeping nodejs)
    Warning, ignoring local change of Instances: 1 (keeping 0)
    Warning, ignoring local change of Memory   : 256 (keeping 0)
Warning, ignoring local change of Url      :     Added   oneanddone.paas.allizom.org

If I try to create the app with the 1.7.4 client, it works without any issues (except the SSH issue from bug 956819, but whatever).
(Assignee)

Comment 1

5 years ago
Can you attach a copy of your stackato.yml file to this bug? I had a similar issue when upgrading my client and had to restructure my yml file but am not sure what all I did now.
(Reporter)

Comment 2

5 years ago
Created attachment 8357335 [details]
stackato.yml

CRACKATOW
(Assignee)

Comment 3

5 years ago
So a couple of things I did to fix some of the errors I see are to add these to my app:

url: mediawikitest.paas.allizom.org
instances: 1
mem: 256M
disk: 2048M

and when I deploy I use the -n flag:
stackato push -n

The combination of the url: and the -n will make it stop asking all the inane questions. As you can see I had to add mem: disk: and instances: to get rid of those errors.

Additionally you can try running this in another window while it is staging and you might get a better error. The end of the pastebin shows a staging failure but not the error with it:
stackato logs --follow mediawikitest

With your appname of course.

Finally I am not sure about the framework error. That one is new to me and I see no reason why it does not work. Can you make these changes and try deploying while --follow the logs and hopefully report back any new errors?
(Reporter)

Comment 4

5 years ago
Helpfully, re-running push now results in the app being created with no issues, with and without the stackato.yml fixes above. I can replicate the issues I saw two days ago. :(

Should we just chalk this up to intermittent issues and close out the bug?
(Assignee)

Comment 5

5 years ago
Yea that sounds fine. The only other thing I can think of is if it was a first run than perhaps something was not created in the correct order and the second run therefore worked. I had this with one app due to a database table creation issue.

Either way I will close this now but do let me know if you have any more issues.
Assignee: server-ops-webops → jcrowe
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.