Closed Bug 957584 Opened 9 years ago Closed 9 years ago

Incorrect CSS rules in the Settings/Downloads panel

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
1.3 C2/1.4 S2(17jan)

People

(Reporter: kaze, Assigned: borjasalguero)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(2 files)

46 bytes, text/x-github-pull-request
borjasalguero
: feedback+
Details | Review
46 bytes, text/x-github-pull-request
kaze
: review+
arcturus
: review+
Details | Review
Following bug 935088, these CSS warnings are reported by adb:

E/GeckoConsole( 2855): [JavaScript Warning: "Error in parsing value for 'overflow'.  Declaration dropped." {file: "app://settings.gaiamobile.org/style/downloads.css" line: 34 column: 12 source: "  overflow: none;"}]
E/GeckoConsole( 2855): [JavaScript Warning: "Unknown property '-moz-boz-sizing'.  Declaration dropped." {file: "app://settings.gaiamobile.org/style/downloads.css" line: 126 column: 17 source: "  -moz-boz-sizing: border-box;"}]
E/GeckoConsole( 2855): [JavaScript Warning: "Unknown property '-moz-boz-sizing'.  Declaration dropped." {file: "app://settings.gaiamobile.org/style/downloads.css" line: 132 column: 17 source: "  -moz-boz-sizing: border-box;"}]
Depends on: 935088
Keywords: regression
Attached file patch
Borja, feel free to steal this bug if you want. :-)
Assignee: nobody → kaze
Attachment #8357114 - Flags: review?(arthur.chen)
Attachment #8357114 - Flags: feedback?(borja.bugzilla)
Kaze! If you want I could take this and try to fix the '!important' in the CSS modifying the JS code. Wdyt? Thanks!
Hey Borja, that’d be nice. :-)
Assignee: kaze → borja.bugzilla
Comment on attachment 8357114 [details] [review]
patch

Cleaning the flags. I'll try to fix as well the hide class using 'hidden' attribute. Thanks!
Attachment #8357114 - Flags: review?(arthur.chen)
Attachment #8357114 - Flags: feedback?(borja.bugzilla)
Attachment #8357114 - Flags: feedback+
Whiteboard: [systemsfe]
Attached file Pull request
Attachment #8359214 - Flags: review?(kaze)
Attachment #8359214 - Flags: review?(francisco.jordano)
Comment on attachment 8359214 [details] [review]
Pull request

Incredible job, so clean now!

Thanks, tried on the phone and works perfectly, just left one ni on github.
Attachment #8359214 - Flags: review?(francisco.jordano) → review+
Comment addressed! Kaze, r?
Duplicate of this bug: 959961
Duplicate of this bug: 959965
Comment on attachment 8359214 [details] [review]
Pull request

R=me with nits addressed, see my comments on github regarding the use of boolean attributes.

This is a very nice cleanup, thanks Borja!
Attachment #8359214 - Flags: review?(kaze) → review+
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
You need to log in before you can comment on or make changes to this bug.